Bug Hunting Session
Bug 123232 - LibreOffice 6.2.0 installed in OpenSuse does not run, just try starting and stops
Summary: LibreOffice 6.2.0 installed in OpenSuse does not run, just try starting and s...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-07 17:32 UTC by kivi
Modified: 2019-09-20 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kivi 2019-02-07 17:32:08 UTC
I have downloaded the LibreOffice 6.2.0 from The Document Foundation site and installed it as root from CLI in openSUSE Leap 15.0.
This installation was done in parallel to already installed LibreOffice 6.1.5.
The installed LibreOffice 6.1.5 on the same computer works as expected.
But when I try to start installed LibreOffice 6.2.0 the start logo shows for a moment and after it northing more happens.
I tried to start it form CLI but it stars for a moment and after it disappears.
Comment 1 Xisco Faulí 2019-02-12 00:53:37 UTC
Hello kivi,
thanks for reporting this issue.
Do you get undefined symbol: gdk_wayland_display_get_type when calling from CLI ?bug 123080 ?
Comment 2 kivi 2019-02-12 09:27:21 UTC Comment hidden (obsolete)
Comment 3 kivi 2019-02-12 09:32:57 UTC
Hi Xisco

The software starts, the form with the logo and the slider at the bottom appears. Once the slider reaches the middle, the program stops working without any messages and this form disappears from the screen.
However, when tried by CLI to run it with additional options, it showed a Segmentation Fault message or something like this, then disappeared again. There are also no crash reports during such tests.

I can not found any messages about gdk_wayland_display_get_type when calling from CLI.
I am using the KDE desktop even have also GTK installed but only as needed for some other software to work correctly.

And yes, I do not use Wayland and do not have it installed.
It may be connected with the bug you pointed me to see.
(Sorry unfortunately this last sentence I have written in the comments to the bug  ?bug 123080)
Comment 4 kivi 2019-03-07 14:00:47 UTC
Dear Xisco,

I have tested the new release - LibreOffice 6.2.1.2.
It works as expected - I can install it, then start it and it is starting as expected.

But there is another problem.
All former version when downloaded from the TDF site had a info link, consisting the check sums of the packages.

Now for LibreOffice 6.2.1.2 these check sums of the packages are missing when I open the info link. Now it is a pain to found the correct check sum for the correct package as packages are a huge amount.
Many people can not found them at all.

I do not know how to report it?
Shall I wrote a bug report?
How to ask to make the check sums available again in the info link from the site?
Comment 5 Robert Cabane 2019-03-09 00:09:55 UTC
I have the very same problem here :
OpenSUSE 15.0 + X11 + KDE (updated KDE 5.12.5) (no Wayland)
LO 6.2.0 and 6.2.1
Launched from CLI with -v switch
Error message :
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException' 
This is a blocker. I uninstalled LO 6.2 and reverted to LO 6.1.
Comment 6 Robert Cabane 2019-03-10 09:20:37 UTC
See also :
https://bugs.documentfoundation.org/show_bug.cgi?id=102495
Comment 7 Jean-Baptiste Faure 2019-03-10 16:06:04 UTC
@kivi: please try to start LibreOffice 6.2 in a terminal using the following command line:
SAL_USE_VCLPLUGIN=gen libreoffice6.2
or
SAL_USE_VCLPLUGIN=gtk3 libreoffice6.2

Does that work for you ?

Status is set to NEEDINFO, please set it back to UNCONFIRMED once you have provided requested information.

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2019-03-10 16:07:43 UTC
(In reply to Robert Cabane from comment #5)
> I have the very same problem here :
> OpenSUSE 15.0 + X11 + KDE (updated KDE 5.12.5) (no Wayland)
> LO 6.2.0 and 6.2.1
> Launched from CLI with -v switch
> Error message :
> terminate called after throwing an instance of
> 'com::sun::star::uno::DeploymentException' 
> This is a blocker. I uninstalled LO 6.2 and reverted to LO 6.1.

Not sure if that is the same problem as one reported by kivi because He did not have this error message.

Best regards. JBF
Comment 9 Robert Cabane 2019-03-10 19:05:20 UTC
Answer : absolutely no change for me with the indicated commands 
SAL_USE_VCLPLUGIN=gen libreoffice6.2
or 
SAL_USE_VCLPLUGIN=gtk3 libreoffice6.2
or 
SAL_USE_VCLPLUGIN=qt5 libreoffice6.2
I get the same error message, anyway. And also the same when starting with --safe-mode.
Comment 10 Michael Weghorn 2019-03-13 09:17:57 UTC
(In reply to kivi from comment #4)
> I have tested the new release - LibreOffice 6.2.1.2.
> It works as expected - I can install it, then start it and it is starting as
> expected.

As far as I understand, this means that the initial bug no longer exists and this bug report can be closed as RESOLVED WORKSFORME?

> 
> But there is another problem.
> All former version when downloaded from the TDF site had a info link,
> consisting the check sums of the packages.
> 
> Now for LibreOffice 6.2.1.2 these check sums of the packages are missing
> when I open the info link. Now it is a pain to found the correct check sum
> for the correct package as packages are a huge amount.
> Many people can not found them at all.
> 
> I do not know how to report it?
> Shall I wrote a bug report?
> How to ask to make the check sums available again in the info link from the
> site?

Can you give a step-by-step description what exactly you do? (and in what step there used to be a info link with the check sums)


@Robert Cabane: Please open a new bug report for your issue, since it seems to be a different one. Handling one aspect in one bug report helps to focus on one aspect at a time and avoid confusion.
Comment 11 Robert Cabane 2019-03-15 21:08:47 UTC
OK, done here :
https://bugs.documentfoundation.org/show_bug.cgi?id=124110
Comment 12 QA Administrators 2019-09-12 02:51:52 UTC Comment hidden (obsolete)
Comment 13 j0w2kds9 2019-09-14 05:46:55 UTC Comment hidden (spam)
Comment 14 Timur 2019-09-19 12:33:33 UTC
Looks like safe to close.
Comment 15 kivi 2019-09-20 07:41:30 UTC
Please close it.
This problem was solved by next minor release.
Comment 16 Michael Weghorn 2019-09-20 08:47:08 UTC
(In reply to kivi from comment #15)
> Please close it.
> This problem was solved by next minor release.

OK, thanks for the update.