Bug 123238 - LibreOffice 6.2 Writer does not remember last view in a document - Mac only
Summary: LibreOffice 6.2 Writer does not remember last view in a document - Mac only
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-02-07 20:29 UTC by Claude
Modified: 2019-04-19 08:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claude 2019-02-07 20:29:41 UTC
Description:
When opening an odt document in Writer 6.2, it does not remember the last emplacement. 

Usually, when I open a document created earlier, the document opens at the last place I was the last time.

Steps to Reproduce:
1.Open a previously saved text document in odt format.
2.Place the cursor at the end of the document. Save. Close the document and/or quit LibreOffice
3.Open the saved document. Check where the cursor is. 

Actual Results:
Normally, the cursor should be where it was when you saved the document earlier. But now, it's at the beginning of the text.

Expected Results:
The cursor should be where it was the last time you saved the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Timur 2019-02-08 13:19:58 UTC
Do you have user data filled? 
Please see https://help.libreoffice.org/Common/Opening_Documents#Cursor_Position
Comment 2 Claude 2019-02-08 15:00:28 UTC
(In reply to Timur from comment #1)
> Do you have user data filled? 


Yes, of course. That’s the only way it works. It is working in 6.1.5

And I even tried a clean install of LibreOffice 6.2, so the user was more than reset.
Comment 3 Timur 2019-02-08 16:30:24 UTC
I don't repro in LO 6.3+ in Windows.
So, this may be either Mac specific or you use Web view (bug 116099) or you didn't reset user profile (not sure what's "clean install", did you delete user profile before).
Comment 4 Claude 2019-02-08 16:35:29 UTC
Just a regular text saved in odt format.

By clean install. I mean wiping anything LibreOffice on the hard drive.

Maybe it’s MacOS specific. Last time, the LibreOffice team had to compile the 6.1.4 version in a new Xcode. 

But you might want to check in LibreOffice 6.2 and not 6.3.
Comment 5 Alex Thurgood 2019-02-11 15:55:33 UTC
Confirmed with

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
Threads CPU : 4; OS : Mac OS X 10.14.2; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 6 Claude 2019-02-15 05:08:44 UTC
I've tried the LibreOffice 6.2.1.1 version.

It's working in that development version.

Hope all will be good for the next release of 6.2.1
Comment 7 Timur 2019-02-15 10:51:29 UTC
According to what you wrote, it's "WorksForMe". 
But please feel free to set again Unconfirmed if that repeats.
Comment 8 Timur 2019-02-15 10:53:15 UTC
Sorry, I didn't notice confirmation. Alex and Claude, please test with master.
Comment 9 Claude 2019-02-18 05:36:08 UTC
(In reply to Timur from comment #7)
> According to what you wrote, it's "WorksForMe". 
> But please feel free to set again Unconfirmed if that repeats.

Well, to be precise, it's not working as well as version 6.1.5 

In version 6.2.1.1, the cursor is not at the exact same spot.

So, for now, untill version 6.2.1 gets out, I'll mark it again as "Confirmed".
Comment 10 Timur 2019-02-18 13:14:34 UTC
If there's a will no need to wait, please test with daily master from https://dev-builds.libreoffice.org/daily/master/.
Comment 11 Claude 2019-03-04 00:23:50 UTC
Just tried the latest "Development version" 6.2.1 RC2

Same problem. Not fixed.
Comment 12 Dieter Praas 2019-03-04 10:41:35 UTC
(In reply to Claude from comment #2)
> It is working in 6.1.5

So it seems to be a regression => Keywords possibleRegression, bibisectRequest
Comment 13 Claude 2019-03-04 16:58:11 UTC
(In reply to Dieter Praas from comment #12)
> (In reply to Claude from comment #2)
> > It is working in 6.1.5
> 
> So it seems to be a regression => Keywords possibleRegression,
> bibisectRequest


Thank you for the precisions.

I'm not a developper, just a reguar user.
Comment 14 Claude 2019-03-08 18:43:20 UTC
Should I test the LibreOffice 6.2.2 RC1 version?

I have a feeling that bug/regression for MacOS is not on the radar.
Comment 15 Claude 2019-03-21 18:51:44 UTC
Just to report that new version of Libreoffice 6.2.2 still has a bug/regression on MacOS.

I'm a (french) writer. I use LibreOffice for my work. Opening a 200 pages document and having to scroll each time to the last place I was yesterday is tedious.

I hope some developper who has a Mac can fix this before the 6.2 cycle is over.

Thanks.
Comment 16 Alex Thurgood 2019-03-22 13:42:15 UTC
Confirming that bug is still present in 

Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
Threads CPU : 4; OS : Mac OS X 10.14.3; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

the document is re-opened with the cursor apparently positioned at an offset to the right of where the cursor was last positioned.
Comment 17 Claude 2019-04-18 20:47:30 UTC
The bug/regression appears to be fixed in the new version of LibreOffice on my Mac (Mojave 10.14.4) 

LibreOffice Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac

So many thanks!

Waiting for others to confirm.
Comment 18 Dieter Praas 2019-04-19 08:41:47 UTC
(In reply to Claude from comment #17)
> The bug/regression appears to be fixed in the new version of LibreOffice on
> my Mac (Mojave 10.14.4) 

Claude, if you're no longer able to reproduce it, you are allowed to close the bug as RESOLVED WORKSFORME (I did it now).