Bug 123245 - Image Anchor does not hold 'to page'
Summary: Image Anchor does not hold 'to page'
Status: RESOLVED DUPLICATE of bug 49179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOC-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2019-02-08 02:15 UTC by Kalen
Modified: 2019-02-09 14:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Requested sample file for image anchor bug report 123245 (416.00 KB, application/msword)
2019-02-08 19:13 UTC, Kalen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kalen 2019-02-08 02:15:57 UTC
Description:
Image anchor set to hold image 'to page'. Save document. Close document. Reopen document. Anchor /always/ resets 'to character'. Many previous versions of LibreOffice have had this happen.

Steps to Reproduce:
1. Insert image into document
2. Set image Anchor 'to Page'
3. Save and close document
4. reopen document and check anchor setting.

Actual Results:
Image anchor reset 'to character' and reset other formatting and line breaks in top two or three lines.

Expected Results:
Maintained the 'to page' anchor and not modified any other formatting on the page.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-02-08 09:41:00 UTC
(In reply to Kalen from comment #0)
> Many previous
> versions of LibreOffice have had this happen.

Thank you for reporting the bug. Please add informations from HELP => About LibreOffice to make clear, what version you are using. Thank you for reporting the bug. It seems you're using an old version of LibreOffice. If you are not using the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ please try to repdroduce it with that version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Kalen 2019-02-08 16:20:02 UTC
Updated version info, but problem has persisted for several versions over the last year or so. (Only noticed because I only started adding images to documents over the last year.)

Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: en-CA (en_CA); Calc: group threaded
Comment 3 Telesto 2019-02-08 18:56:06 UTC
A sample file would really helpful. I can't reproduce it
Comment 4 Kalen 2019-02-08 19:13:56 UTC
Created attachment 149029 [details]
Requested sample file for image anchor bug report 123245

Saved as Word 97-2003 (.doc) format.
Comment 5 Telesto 2019-02-08 20:04:35 UTC
Conforming with
Version: 6.3.0.0.alpha0+
Build ID: 0b21f6556b6fff76290d1095089da89532365215
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

and with
4.4.7.2

For DOC & DOCX file-format

But not an expert on file-format compatibility
Comment 6 Dieter 2019-02-08 22:22:55 UTC
=> NEW bcause of comment 5
Comment 7 Regina Henschel 2019-02-08 23:52:54 UTC
Word has no feature "anchor to page".

I think, duplicate to bug 49179.
Comment 8 Kalen 2019-02-09 00:06:04 UTC
(In reply to Regina Henschel from comment #7)
> Word has no feature "anchor to page".
> 
> I think, duplicate to bug 49179.

Apparently none of the formats I have tried have succeeded in maintaining the 'anchor to page' option I require for these documents. (Word 97-2003 and Word 2007-2019, and Open Office XML Text (.doc and .docx formats))

Which format should I use if this isn't a bug? If the feature doesn't work, why is it maintained as an option?
Comment 9 Telesto 2019-02-09 09:30:09 UTC
LibreOffice/ODT
There are historical reason foor the existence of 'anchoring to page' for LibreOffice native format (ODT). Some info from bug 49179 comment 17

Years ago page anchoring was the only way to put a frame/picture to any position on the page. A frame anchored to a paragraph could not be located e.g. on top of the page.  Later other anchor types were extended to make that possible. So now page anchoring has no advantages anymore. Disadvantages are that other applications might not be able to put the object to the right page because they might create a different layout or they might not have any layout at all (e.g. xslt transformations)

DOC/DOCX
Anchoring to page is a LibreOffice anchoring type. There s no to-page anchoring equivalent in the file-format of MS Word.

*** This bug has been marked as a duplicate of bug 49179 ***
Comment 10 Kalen 2019-02-09 14:50:48 UTC
(In reply to Telesto from comment #9)
> LibreOffice/ODT
> There are historical reason foor the existence of 'anchoring to page' for
> LibreOffice native format (ODT). Some info from bug 49179 comment 17
> 
> Years ago page anchoring was the only way to put a frame/picture to any
> position on the page. A frame anchored to a paragraph could not be located
> e.g. on top of the page.  Later other anchor types were extended to make
> that possible. So now page anchoring has no advantages anymore.
> Disadvantages are that other applications might not be able to put the
> object to the right page because they might create a different layout or
> they might not have any layout at all (e.g. xslt transformations)
> 
> DOC/DOCX
> Anchoring to page is a LibreOffice anchoring type. There s no to-page
> anchoring equivalent in the file-format of MS Word.
> 
> *** This bug has been marked as a duplicate of bug 49179 ***

So, basically what's being said is that I have to go into the properties for the image and set absolute position in the 'Type' tab for the image to stay where I want it. Or to save as the less common file type of ODT.