Bug 123248 - Gridlines do not show in Calc Charts
Summary: Gridlines do not show in Calc Charts
Status: RESOLVED DUPLICATE of bug 121241
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-02-08 04:35 UTC by Corey Bodendein
Modified: 2019-02-11 08:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Basic example spreadsheet showing bug (13.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-08 04:36 UTC, Corey Bodendein
Details
Screenshot of bug with horizontal gridlines enabled, but not visible (225.18 KB, image/png)
2019-02-08 04:37 UTC, Corey Bodendein
Details
Screenshot in safe mode (177.88 KB, image/png)
2019-02-09 00:24 UTC, Corey Bodendein
Details
Works on 6.1.5 (192.11 KB, image/png)
2019-02-09 00:54 UTC, Corey Bodendein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Corey Bodendein 2019-02-08 04:35:55 UTC
Description:
When horizontal or vertical gridlines are chosen to be shown on a Calc chart, they are not visible. Basic example spreadsheet attached.

Steps to Reproduce:
1. Create a new Calc spreadsheet
2. Enter some basic data to use in a chart
3. Add a chart, select the data
4. Try to show horizontal or vertical gridlines

Actual Results:
Horizontal/vertical gridlines are not visible

Expected Results:
Horizontal/vertical gridlines should be visible


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Corey Bodendein 2019-02-08 04:36:44 UTC
Created attachment 149003 [details]
Basic example spreadsheet showing bug
Comment 2 Corey Bodendein 2019-02-08 04:37:52 UTC
Created attachment 149004 [details]
Screenshot of bug with horizontal gridlines enabled, but not visible
Comment 3 Durgapriyanka 2019-02-08 17:10:34 UTC
Thank you for reporting the bug. I cannot reproduce the bug. The horizontal and vertical gridlines are visible.

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Corey Bodendein 2019-02-09 00:24:55 UTC
Created attachment 149031 [details]
Screenshot in safe mode

I attached a screenshot running in safe mode and I still have the missing gridline issue.
Comment 5 Corey Bodendein 2019-02-09 00:30:56 UTC
Here is my LibreOffice version details:

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 8; OS: Mac OS X 10.14.3; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Corey Bodendein 2019-02-09 00:54:13 UTC
Created attachment 149032 [details]
Works on 6.1.5

This works fine for me on 6.1.5.

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 8; OS: Mac OS X 10.14.3; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

So something changed in 6.2.0.
Comment 7 Corey Bodendein 2019-02-09 01:38:31 UTC
This may be specific to macOS.
Comment 8 raal 2019-02-10 17:17:39 UTC
MacOs bug
Works in Version: 6.2.0.0.alpha1+
Build ID: a20a2d7e0d28658f2d9089da076961a599833a28
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 9 Alex Thurgood 2019-02-11 08:52:34 UTC
They are barely visible in 

Version: 6.3.0.0.alpha0+
Build ID: e9db8eceff48290be72591f7422b4fc45e5752fc
CPU threads: 4; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

but extremely faint (very pale grey).

This problem has also been reported for borders.

*** This bug has been marked as a duplicate of bug 121241 ***