Bug 123268 - Hide legend entry - chart lost
Summary: Hide legend entry - chart lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.0.0 target:6.4.3
Keywords: implementationError
: 72559 89722 125291 (view as bug list)
Depends on:
Blocks: Chart-Legends
  Show dependency treegraph
 
Reported: 2019-02-08 14:51 UTC by raal
Modified: 2020-03-25 15:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2019-02-08 14:51:23 UTC
Description:
Tested
Version: 6.3.0.0.alpha0+
Build ID: f8c4459bbda62cb905d0c007cac044f3410ab76b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Steps to Reproduce:
open file https://bugs.documentfoundation.org/attachment.cgi?id=148984
edit chart, click on data point
right click , choose Format data series
click Hide legend entry
OK

Actual Results:
chart lost,

Expected Results:
no change


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-02-08 14:52:12 UTC
 Markus, please, can you look?

4f8b8e4f6dd19d2bc0dd71726c7c7f1b5b5ed3b5 is the first bad commit
commit 4f8b8e4f6dd19d2bc0dd71726c7c7f1b5b5ed3b5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Dec 6 00:02:12 2018 -0800

    source sha:19b2ed4dee1ec33ad55473d43bfcd0bfa194cbee

author    Markus Mohrhard <markus.mohrhard@googlemail.com>    2018-12-05 04:34:39 +0100
committer    Markus Mohrhard <markus.mohrhard@googlemail.com>    2018-12-05 15:43:42 +0100
commit    19b2ed4dee1ec33ad55473d43bfcd0bfa194cbee (patch)
tree    84652611e1378794544ce26d653ba3c4f3a33f27
parent    c32a4c2fac32b766a05473d037d73cbcd972dadd (diff)
related tdf#51671, add UI options for new "hide legend entry" feature
Comment 2 Xisco Faulí 2019-05-09 09:55:18 UTC
Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 64faea31f7d05e46fe5c91f87381ec7abae90174
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Commit Notification 2020-03-06 09:43:31 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/300e65cc47f3d6ae1563350757dbfadc080d7452

tdf#123268 fix lost chart if all legend entries are hidden

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Gabor Kelemen 2020-03-12 06:24:45 UTC
*** Bug 89722 has been marked as a duplicate of this bug. ***
Comment 5 Gabor Kelemen 2020-03-12 06:27:19 UTC
*** Bug 125291 has been marked as a duplicate of this bug. ***
Comment 6 Gabor Kelemen 2020-03-12 06:30:51 UTC
*** Bug 72559 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2020-03-25 15:02:40 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/730369b8670590cb9625691fa2c0008e904fb4e1

tdf#123268 fix lost chart if all legend entries are hidden

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.