Bug 123291 - UI: Hex color input box for changing column chart node color doesn't work
Summary: UI: Hex color input box for changing column chart node color doesn't work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords:
Depends on:
Blocks: Area-Fill-Tab-Color
  Show dependency treegraph
 
Reported: 2019-02-09 14:37 UTC by Ming Hua
Modified: 2019-03-29 21:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2019-02-09 14:37:37 UTC
When trying to change the color of a single node in a column chart, I started editing the chart, selected the node, and right-clicked to choose "Format Data Point...".  I was presented with a pop-up window, with all the tabs for different aspects of the node.

On the "Area" tab, the default is solid color, and there were "Active" and "New" colors presented to me.  Using the RGB value or color picker to change the new color worked fine, however when I tried to directly input the hex value of the new color, it didn't work.  I could only type one character in the hex input box, and further characters were ignored.

I believe I've had this problem for a while, so it's not specific to version 6.1.5.  I assume it's easy to duplicate, but if necessary, I have version 5.2.7 and 6.2.0 installed as well, and am happy to try those versions as well.

Thanks.
Comment 1 Roman Kuznetsov 2019-02-26 19:59:01 UTC
repro in

Version: 6.3.0.0.alpha0+
Build ID: b45289e48e0f354b9996e2846dd041db4a9947ce
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-08_12:51:03
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

not only for chart options in Calc but for all Area tab -> Color in LO
Comment 2 wpeaton4 2019-03-19 23:16:47 UTC
Reproduced in Windows on 6.1.5.2.

This affects every LibO component because they all use Format...Area dialog box. 

Entering by hand a hex html-style color very annoying (you have to select each character one by one and then type a replacement character). And it is impossible to paste a hex color.

Another workaround is to click the "Pick" button and edit the hex color box in that dialog -- it works as expected.
Comment 3 Xisco Faulí 2019-03-25 15:22:43 UTC
I believe the problem is:

1. Go to writer
2. Format - Page - Area - Color
3. type F six times in the hex text box

-> Resulting value is 000000

Reproduced in

Version: 5.3.0.0.alpha1+
Build ID: 4136757b4e51c4e6f7cb4132c95538a7f831ef2c
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Caolán, @Jim, I thought you might be interested in this issue...
Comment 4 Commit Notification 2019-03-27 08:58:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f1e52cbdd4a9753a9b9d562ef280a00e52db1dae%5E%21

Resolves: tdf#123291 set hex input to overwrite by default

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2019-03-27 09:03:03 UTC
If we set it to overwrite mode, and fix a few other things, then it works better
Comment 6 Xisco Faulí 2019-03-28 13:40:39 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: e74de110d16c95414fac7541c8fe6541d4597113
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 7 Commit Notification 2019-03-29 21:25:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/0198259e4301a45c339fcdda688892e1e6a3ad9f%5E%21

Resolves: tdf#123291 set hex input to overwrite by default

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.