Bug 123308 - LibO impress gets confused when copying into a presentation some slides from another presentation whose masters have the same names
Summary: LibO impress gets confused when copying into a presentation some slides from ...
Status: RESOLVED DUPLICATE of bug 112697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Master-Slide
  Show dependency treegraph
 
Reported: 2019-02-10 16:19 UTC by Callegar
Modified: 2019-04-02 14:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2019-02-10 16:19:18 UTC
Description:
Suppose that I have a presentation A with master pages "cover", "standard", "extra".  Now suppose that I have another presentation B with master pages "start", "standard" and "end". If I copy a slide from B (type standard) into A, then LiBO gets confused with respect to master pages, because of the overlapping name.  For instance, working in A and trying to assign the standard master from B to other slides does not work and LibO may even crash.

I think that libO should copy the slide from B into A while renaming "standard" from B into something like "standard_1" to avoid the name clash.

If you do that manually, before copying the slides, then everything works fine.

Seen on LibO 6.1.5.2 and 6.2.0.3, but the issue is probably older.


Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Xisco Faulí 2019-02-11 15:57:36 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Aron Budea 2019-04-02 14:09:28 UTC
Looks a lot like bug 112697, let me close this as duplicate, but if you could provide details on more serious cases, eg. crashes in that bug report, that would be appreciated.

*** This bug has been marked as a duplicate of bug 112697 ***