Download it now!
Bug 123346 - FILESAVE | DOCX, Arrows head style changes when saving in LO
Summary: FILESAVE | DOCX, Arrows head style changes when saving in LO
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: low minor
Assignee: Szabolcs Toth
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords: bibisected, bisected, filter:docx, regression
: 132346 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-02-11 14:15 UTC by NISZ LibreOffice Team
Modified: 2020-05-07 18:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file (22.26 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-11 14:15 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (240.08 KB, image/png)
2019-02-11 14:16 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-11 14:15:06 UTC
Description:
When a normal arrow in a docx created in MSO gets saved in LO as docx the arrows head changes from a V to a filled triangle.

Steps to Reproduce:
    1. Create a new docx in MSO.
    2. Insert a simple arrow.
    3. Save the file.
    4. Open it in LO.
    5. Save it as docx.
    6. Reload.
    7. Notice the changes.


Actual Results:
The arrow’s head is a triangle.

Expected Results:
The arrow should have a V shape as its head after saving in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-02-11 14:15:43 UTC
Created attachment 149128 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-02-11 14:16:03 UTC
Created attachment 149129 [details]
Screenshot of the original and exported document side by side in Writer
Comment 3 Durgapriyanka 2019-02-12 16:04:23 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-02-13 12:09:54 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2d3b7a07c02c90d2d64a630ab84886ef3096edfc

author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>	2017-07-21 18:40:20 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-07-26 08:14:21 +0200
commit	2d3b7a07c02c90d2d64a630ab84886ef3096edfc (patch)
tree	bd6060e696724dbacdb5e9e184c4868241a2a9d9
parent	0efd702828abcfdcfb0799d9cf3de8d25c9c19b5 (diff)
tdf#100491 fix DOCX import shape line with arrow marker

Bisected with: bibisect-linux64-6.0

Adding Cc: to Vasily Melenchuk
Comment 5 Commit Notification 2020-04-20 09:13:53 UTC
Szabolcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/68531e459e7a922319e6bfe8b7a5282ba0320182

tdf#123346 DOCX VML shape export: fix arrow marker

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-04-21 15:05:40 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 850b8de31c5be5127eac16a4f5cc18c26a582e53
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Szabolcs Toth, thanks for fixing this issue!!
Comment 7 Commit Notification 2020-04-21 16:45:03 UTC
Szabolcs committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a01bcc88af9d1ac47af64abab95f9048b4870740

tdf#123346 DOCX VML shape export: fix arrow marker

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 NISZ LibreOffice Team 2020-05-07 18:31:29 UTC
*** Bug 132346 has been marked as a duplicate of this bug. ***