Bug Hunting Session
Bug 123378 - (6.2 Regression) Printing always sets "document modified" status
Summary: (6.2 Regression) Printing always sets "document modified" status
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
: 123979 (view as bug list)
Depends on:
Blocks: ModifiedStatus
  Show dependency treegraph
 
Reported: 2019-02-12 01:21 UTC by Lenge
Modified: 2019-03-13 14:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lenge 2019-02-12 01:21:52 UTC
Description:
After the upgrade to release 6.2, I notice set printing always sets the  "document modified" status regardsless of the respective setting.

Tools\Options...\LibreOffice\General\Document Status
[ ] Printing set the "document modified" status

Steps to Reproduce:
Uncheck the respective option.

Actual Results:
Printing sets the "document modified" status nonetheless.

Expected Results:
Printing shouldn't touch the "document modified" status (like it was before 6.2).


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-02-12 12:15:16 UTC
I can't reproduce it in

Versión: 6.2.0.3
Id. de compilación: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 Lenge 2019-02-12 13:56:58 UTC
I have just tested with a fresh user profile: Same bug.

The document status is set to "modified" as soon as you click "File\Print..." in the menu. The red dot in the "Save" toolbar icon is already present when the printer selection dialog opens (even before the actual printing takes place).
Comment 3 Xisco Faulí 2019-02-12 14:38:32 UTC
I don't know I couldn't reproduce it the first time...

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2bc1d00af6863d5c92389f1f4a99d2ab9bb73f81

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2018-12-13 19:58:36 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2018-12-15 15:00:51 +0100
commit	2bc1d00af6863d5c92389f1f4a99d2ab9bb73f81 (patch)
tree	9e870b5415a691d9faefbb943164595c35783c1f
parent	21b81b07b01e4482a80ced8dcdf48c480031c3c8 (diff)
tdf#121962 Update fields after layout has been calculated

Bisected with: bibisect-linux64-6.3 

Adding Cc: to Samuel Mehrbrodt
Comment 4 Commit Notification 2019-02-13 11:06:18 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ac1b2c9e1ab2f84de3a8856772e00302d237e82f%5E%21

tdf#123378 Prevent modifying doc when printing

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-02-13 15:58:55 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ffd826d0e421a7634ac742439ecd0e7563b3eb4d%5E%21

tdf#123378 Prevent modifying doc when printing

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-02-14 10:17:13 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-1":

https://git.libreoffice.org/core/+/130719bdba770f1c9ac634f436bab3285fef7a1a%5E%21

tdf#123378 Prevent modifying doc when printing

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-02-14 14:39:07 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 6c1588fd22baa0f315e38ecd22591cf13b4b9384
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Samuel, thanks for fixing this issue !
Comment 8 luca.manganelli 2019-02-18 10:45:24 UTC
Will the fix be available in LibreOffice 6.1.6?
Comment 9 luca.manganelli 2019-02-18 10:47:20 UTC
In addition to my comment, I'm having this bug in the still version of LibreOffice (actually is 6.1.5)
Comment 10 Samuel Mehrbrodt (CIB) 2019-02-18 10:48:18 UTC
I reverted the commit for 6-1 line, so yes, 6.1.6. will be fixed.

https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-1&id=2ab2280f21fa491154e17c303dc70fcf059123b3
Comment 11 Aron Budea 2019-03-13 14:31:01 UTC
*** Bug 123979 has been marked as a duplicate of this bug. ***