Bug 123435 - FILEOPEN: DOCX: Some shapes are not displayed
Summary: FILEOPEN: DOCX: Some shapes are not displayed
Status: RESOLVED DUPLICATE of bug 129516
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
: 127244 128561 129065 (view as bug list)
Depends on:
Blocks: DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2019-02-13 13:37 UTC by Xisco Faulí
Modified: 2020-09-03 12:12 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
comparison MSO 2010 and LibreOffice 6.3 Master (215.58 KB, image/png)
2019-02-13 13:37 UTC, Xisco Faulí
Details
another file affected (30.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-13 15:07 UTC, Xisco Faulí
Details
console logs (46.49 KB, text/plain)
2019-02-13 18:54 UTC, Julien Nabet
Details
The example file opened in Writer 7.0 (258.38 KB, image/png)
2020-09-03 07:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-02-13 13:37:02 UTC
Created attachment 149264 [details]
comparison MSO 2010 and LibreOffice 6.3 Master

Steps to reproduce:
1. Open attachment 56101 [details] from bug 45193

-> Some shapes are not displayed. See comparison

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 6d52cd1c0b7270a512a8e4ea988432fdad3e4385
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-02-13 13:38:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3272c1eb5563f3bda2caa24f32b1018372622109

author	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-10-01 03:21:59 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-01-07 17:49:44 +0100
commit 3272c1eb5563f3bda2caa24f32b1018372622109 (patch)
tree b4b948fd36ed53b1d8399babf2dbe701469da412
parent 5dfd5755c709e91d2903bd7be4582f7832e89780 (diff)
related tdf#100074: prepare group shapes text input via writerfilter

Bisected with: bibisect-linux64-6.3

Adding Cc: to Thorsten Behrens
Comment 2 Xisco Faulí 2019-02-13 15:07:33 UTC
Created attachment 149269 [details]
another file affected

Another file where the line above 'By: Authorized Signature' is missing.
Comment 3 Julien Nabet 2019-02-13 18:54:52 UTC
Created attachment 149277 [details]
console logs

On pc Debian x86-64 with master sources updated 2 days ago, I could reproduce this.

I attached console logs from first and second attachments.
Comment 4 Xisco Faulí 2019-05-14 14:54:02 UTC
attachment 142198 [details] from bug 117701 is also affected by this issue
Comment 5 Xisco Faulí 2019-09-02 15:29:20 UTC
*** Bug 127244 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2019-09-02 15:49:50 UTC
Increasing severity...
Comment 7 Xisco Faulí 2019-11-04 12:13:18 UTC
*** Bug 128561 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-11-29 15:27:29 UTC
*** Bug 129065 has been marked as a duplicate of this bug. ***
Comment 9 NISZ LibreOffice Team 2020-09-03 07:30:53 UTC
Created attachment 165064 [details]
The example file opened in Writer 7.0

Looks good now in 

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5960c6f4ca9dd6ab4b4081d3be7253468cd212c4

author	Miklos Vajna <vmiklos@collabora.com>	2020-01-13 20:08:54 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2020-01-14 08:50:52 +0100

tdf#129516 DOCX import: fix incorrect z-order with textboxes
Comment 10 NISZ LibreOffice Team 2020-09-03 07:32:44 UTC
Thanks Miklos for fixing this one!

*** This bug has been marked as a duplicate of bug 129516 ***
Comment 11 Timur 2020-09-03 08:08:34 UTC
Thanks also to Nisz for many retests and clearing BZ. 
I checked the duplicates.
Comment 12 Commit Notification 2020-09-03 12:12:37 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a43e781d0920c1534cd44339e624f9cc76ae298

tdf#123435: sw_ooxmlexport13: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.