Download it now!
Bug 123489 - Customized ~ "Automatically move to the next one after joining", "Do not repeat"
Summary: Customized ~ "Automatically move to the next one after joining", "Do not repeat"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.1.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Customise-Dialog
  Show dependency treegraph
 
Reported: 2019-02-15 15:21 UTC by 00
Modified: 2019-11-18 10:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Watch the movie (this is the WPS program) (3.04 MB, video/mp4)
2019-02-15 15:25 UTC, 00
Details
1 (59.42 KB, image/png)
2019-02-15 16:00 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2019-02-15 15:21:37 UTC
Description:
Customized ~ "Automatically move to the next one after joining", "Do not repeat"

"Microsoft Office" and "WPS" have this feature.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2019-02-15 15:25:06 UTC
Created attachment 149314 [details]
Watch the movie (this is the WPS program)
Comment 2 00 2019-02-15 16:00:46 UTC
Created attachment 149315 [details]
1
Comment 3 Xisco Faulí 2019-03-21 14:20:31 UTC
Moving to NEW
Comment 4 Muhammet Kara 2019-11-16 19:39:44 UTC
I would call these behavior design rather than feature. Actually we have the "do not repeat" part in menus, but not in toolbars, and that is by choice.

So should we move to the next item on the functions list after an "add" operation? We need to decide that.
Comment 5 Heiko Tietze 2019-11-18 10:23:52 UTC
Many thanks for your idea. We discussed whether to move or to copy the selected item back when we started the redesign. The decision for copy was taken since users should be able to have a command in multiple sections of the menu/toolbar/notebookbar. So we have to keep the left item. And actually I don't see a reason to click through all commands. For example Copy, Copy Hyperlink Location, Corner Point, Create AutoAbstract... are not related and it makes no sense to put them at the same place.