Bug 123494 - Calc: There are two items "Paste special" in Function list on Toolbars tab in Customize dialog
Summary: Calc: There are two items "Paste special" in Function list on Toolbars tab in...
Status: RESOLVED DUPLICATE of bug 122523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2019-02-16 06:52 UTC by Roman Kuznetsov
Modified: 2019-03-22 15:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (50.37 KB, image/png)
2019-02-16 06:55 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-02-16 06:52:35 UTC
Description:
Calc: There are two items "Paste special" in Function list on Toolbars tab in Customize dialog

And it has different shortcuts Ctrl+Shift+V and Ins, but it works the same -> opens Paste special dialog

I suggest delete the one

Steps to Reproduce:
1. OPen Calc
2. Select menu Tools->Customize->Toolbars tab
3. In Searsh field enter "Paste Special"
4. Look at two items with same names

Actual Results:
There are two items "Paste special" in Function list on Toolbars tab in Customize dialog

Expected Results:
There is only one item "Paste special" in Function list on Toolbars tab in Customize dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-02-16 06:55:36 UTC
Created attachment 149324 [details]
Screenshot
Comment 2 russell 2019-02-17 03:32:14 UTC
I can confirm it appears that there are duplicate "Paste special". 
In 6.0.7.3, 6.1.4.2, & 6.2.0.3.

In addition to "Paste special", there are duplicates of (partial list):

Duplicate text, no icon:
AutoFilter
Bottom
Center
Change Anchor
Default

Duplicate text, same icon:
EPUB

There is a "Insert Cells/no icon" and "Insert Cells/with an icon", same as:
Justified
Manage
Manage Names

This feature has changed, in 6.0 there were duplicate texts, no icons at all, but the Description Box below the Function listbox changed text. See below:

++++++++++
Paste Special 1: Customizes and saves current menu layouts as well as creates new menus.

Paste Special 2: Inserts the contents of the clipboard into the current file in a format that you can specify.
++++++++++

However in 6.1 and 6.2, there are icons, but the Description box is grayed out/disabled, so clicking on the items in the Function listbox does not help distinguish them.
Comment 3 Xisco Faulí 2019-03-22 15:35:41 UTC
Duplicate of bug 122523

*** This bug has been marked as a duplicate of bug 122523 ***