Bug Hunting Session
Bug 123508 - "Fit print range(s) to width/height" value falls back to default when window closes
Summary: "Fit print range(s) to width/height" value falls back to default when window ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-17 02:51 UTC by Kevin Suo
Modified: 2019-09-11 04:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
page scale demo (8.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-17 14:50 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2019-02-17 02:51:20 UTC
Steps to Reproduce:
1. In Calc, go to "Format > Page - Sheet > Scale";
2. Select "Fit print range(s) to width/height" from the scale mode drop-down list, then define a value for the page width or height;
3. Click OK to close the window, and reopen this window again.

Current Result:
The page height/width value falls back to 1.

Expected Result:
The page height/width value should be the value you have defined.

版本: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU 线程: 4; 操作系统: Linux 4.15; UI 渲染: 默认; VCL: gtk2; 
区域语言: zh-CN (zh_CN.UTF-8); Calc: group threaded
Comment 1 m.a.riosv 2019-02-17 09:13:10 UTC
What file format do you use to save?
Comment 2 Oliver Brinzing 2019-02-17 14:50:57 UTC
Created attachment 149352 [details]
page scale demo

attached file has 6 print pages
Comment 3 Oliver Brinzing 2019-02-17 14:55:11 UTC
steps to reproduce with:

Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

- open "Format > Page - Sheet > Scale
- select "Fit print range(s) to width/height" 
  from the scale mode drop-down list
- define a value for the page, e.g.:
  width   2
  height  2
- [OK], sheet has 4 print pages now
- open "Format > Page - Sheet > Scale again:
  width   1
  height  1

works with LO 6.0.7.3, regression
Comment 4 m.a.riosv 2019-02-17 15:01:24 UTC
When I open the file scale is 100&, changing to 2x2, it remains at reopening the format page or reopening the file.

Version: 6.2.1.1 (x64)
Build ID: 757c58e8cb70b2982843211a54750fb3cd79acd5
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 5 Oliver Brinzing 2019-02-17 15:03:27 UTC
yes, just noticed, this seems to have been fixed

not reproducble with:

Version: 6.2.0.3 (x64)
Build-ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 6 raal 2019-02-18 13:27:22 UTC
(In reply to Oliver Brinzing from comment #5)
> yes, just noticed, this seems to have been fixed
> 
> not reproducble with:
> 
> Version: 6.2.0.3 (x64)
> Build-ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
> CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
> Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
> Calc:

Not reproducible with Version: 6.3.0.0.alpha0+
Build ID: 9d7620613d3ea2feb45a7ff57c4d2544bb1c6fe6
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 

Closing the bug.
Comment 7 Kevin Suo 2019-02-18 15:23:22 UTC
I am setting it to NEW because we need to test if the bug is also resolved in the 6.1 branch, as the 6.1 branch isvthe most recent working released version. l
Comment 8 Commit Notification 2019-02-22 05:40:21 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3114e187e5abd34207f220b6d9f42b63b4fe0bd8%5E%21

uitest for bug tdf#123508

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-03-14 18:29:00 UTC
Issue is fixed in master/6.2, thus closing as RESOLVED WORKSFORME
Adding backportRequest to see when it got fixed...