Bug 123545 - A .doc file renamed to something.rtf gets opened as a template ("Untitled 1")
Summary: A .doc file renamed to something.rtf gets opened as a template ("Untitled 1")
Status: RESOLVED DUPLICATE of bug 110987
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-18 15:01 UTC by Tor Lillqvist
Modified: 2019-02-18 15:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2019-02-18 15:01:20 UTC
Description:
Take a .doc file created by Word or LibreOffice. Rename it to have the .rtf extension instead. Open if in LibreOffice. The document will be called "Untitled 1" as LibreOffice for some reason thinks the file is of a template type.

Seems to be present in 6.0, 6.1 and master at least.

Steps to Reproduce:
See above.

Actual Results:
See above.

Expected Results:
The document should be opened normally and be associated to the actual file name from which it was loaded.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Aron Budea 2019-02-18 15:16:27 UTC
This must be for the same reason as bug 110987. I had a simple fix for that, but it caused a regression: bug 119530.

*** This bug has been marked as a duplicate of bug 110987 ***