Bug 123549 - the "close document" button is missing to return to welcome start window
Summary: the "close document" button is missing to return to welcome start window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.1.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords:
: 124317 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-18 19:24 UTC by karsten.henning
Modified: 2019-05-22 05:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the "Close" button for gtk3 (51.76 KB, image/png)
2019-03-24 22:10 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karsten.henning 2019-02-18 19:24:56 UTC
Description:
A return to the welcome window is only possible by closing the document out of the file-menu and close,

the icon "close document" in the upper right corner is not available 

Steps to Reproduce:
1.open writer, calc or any other application
2. you see, that the icon is missing
3. open file-menu and select close
4. you will return to the welcome-Window with the overview of the recent files 

Actual Results:
missing icon "close document"

Expected Results:
the icon "close document" appears in the last window before closing


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 khaymatt1 2019-03-02 01:56:45 UTC
Thank you for reporting the bug. I can not reproduce the bug in Version: 6.2.0.3.
Comment 2 Dieter Praas 2019-03-02 12:35:13 UTC
I'm not sure at all, but I think this button was never there by default (I can't see it in the LO 6.3.0.0). You can add it with tools => customize => toolbars.

If you think, it should be there by default, then you should adjust this bug report.
Comment 3 karsten.henning 2019-03-02 21:19:30 UTC
The icon is present in the same version under MS-Windows and it was present in all Versions 6.0.*, 6.1.* and 6.2.0.* before.

The icon also missing in Version 6.2.1.2!
Comment 4 Dieter Praas 2019-03-03 11:55:26 UTC
(In reply to karsten.henning from comment #3)
> The icon is present in the same version under MS-Windows

I only use Windows, so perhaps it's only a Linux Bug
Comment 5 Xisco Faulí 2019-03-13 21:39:33 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 8aa579830b20072af8d6e149d6b279362fe98b91
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 6 karsten.henning 2019-03-14 17:10:15 UTC
Version: 6.2.2.1
Build-ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

May be it is only a bug in KDE?
Comment 7 Xisco Faulí 2019-03-22 15:34:34 UTC
(In reply to karsten.henning from comment #6)
> Version: 6.2.2.1
> Build-ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
> CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: kde5; 
> Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
> Calc: threaded
> 
> May be it is only a bug in KDE?

Could you please try to launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3 to see if the button is there ?
Comment 8 karsten.henning 2019-03-22 17:47:43 UTC
Yes it works with this gtk-environment.

I started with this command line:

$ export SAL_USE_VCLPLUGIN=gtk3; libreoffice6.2 --calc


(soffice:3149): Gdk-WARNING **: 17:22:02.857: XSetErrorHandler() called with a GDK error trap pushed. Don't do that.
$
Comment 9 Michael Weghorn 2019-03-24 22:10:57 UTC
Created attachment 150265 [details]
Screenshot showing the "Close" button for gtk3

Confirmed with

Version: 6.3.0.0.alpha0+
Build ID: c18179cf80516f1eca9629a0a8b888e0ca67a020
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded


I'm attaching a screenshot that shows the "Close" button for the gtk3 VCL plugin (s. red rectangle in screenshot).
Comment 10 Xisco Faulí 2019-03-25 18:14:35 UTC
*** Bug 124317 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2019-05-07 15:43:35 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8ea988f585db72da88994d29d006f1976007789d%5E%21

tdf#123549 Qt5 implement Qt5Menu::ShowCloseButton

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-05-22 05:16:07 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/f10c1c648e698b48dfaa679a4909b3d9de6ed868%5E%21

tdf#123549 Qt5 implement Qt5Menu::ShowCloseButton

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.