Download it now!
Bug 123571 - Apple Pages totally blank
Summary: Apple Pages totally blank
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libetonyek (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-19 13:29 UTC by Daniel
Modified: 2021-05-16 18:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Lorem Ipsum.pages (341.99 KB, application/x-zip-compressed)
2019-02-19 13:30 UTC, Daniel
Details
Pages Document that I have made (166.96 KB, image/png)
2019-02-19 13:32 UTC, Daniel
Details
Totally Blank (101.07 KB, image/png)
2019-02-19 13:35 UTC, Daniel
Details
result with current sources of libetonyek (31.42 KB, application/vnd.oasis.opendocument.text)
2019-03-31 18:51 UTC, osnola
Details
Apple pages document (507.68 KB, application/zip)
2020-06-20 17:22 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2019-02-19 13:29:44 UTC
Description:
I have made some sample document like example 'Lorem Ipsum' in Apple Pages Online and I modified or edit. And finally I save as .pages file as default. Then I open it by LibreOffice Writer, it's totally blank.

Steps to Reproduce:
1. Open file in Apple Pages and LibreOffice Writer
2. Only Apple Pages open normally with rich content
3. Totally blank in Writer

Actual Results:
It should show content in Apple Pages as same as Writer

Expected Results:
Totally blank in Writer


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Daniel 2019-02-19 13:30:57 UTC
Created attachment 149416 [details]
Lorem Ipsum.pages
Comment 2 Daniel 2019-02-19 13:32:23 UTC
Created attachment 149417 [details]
Pages Document that I have made
Comment 3 Daniel 2019-02-19 13:35:01 UTC
Created attachment 149418 [details]
Totally Blank

I open that I have made and saved Apple Pages Document before and I open it in Writer and It's totally blank.
Comment 4 raal 2019-02-19 16:05:51 UTC
Confirmwith Version: 6.3.0.0.alpha0+
Build ID: 465939feb0e9c382e5581b53b72008979ece4807
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 5 osnola 2019-03-31 18:51:25 UTC
Created attachment 150433 [details]
result with current sources of libetonyek

Hello,
I have just commit some changes in libetonyek. 

Now the output is not longer blank(see attachment), a problem remains with the headers/footers which are composed of three parts (left/center/right part) as 
currently libetonyek converts each part in a different paragraph.
Comment 6 Marc Pare 2020-03-10 06:39:06 UTC
Is this bug still being worked on? I am also having the same result with a .page file that I was sent. Or, is there a workaround for this?

Many thanks for any information.

Marc
Comment 7 osnola 2020-03-13 09:26:25 UTC
> Is this bug still being worked on?
I have made many changes to the libetonyek code, so it should now be able to retrieve more stuff from recent files. However, for these changes to appear in LibreOffice, a new release of libetonyek must be made (and I don't know how to do that).

> Or, is there a workaround for this?
If you know how to compile it, you can recompile the new libetonyek code see https://wiki.documentfoundation.org/DLP/Libraries/libetonyek and then recompile a standalone version of writerperfect see https://sourceforge.net/p/libwpd/wiki/writerperfect/ ...
Comment 8 Marc Pare 2020-03-13 15:34:12 UTC
(In reply to osnola from comment #7)
> > Is this bug still being worked on?
> I have made many changes to the libetonyek code, so it should now be able to
> retrieve more stuff from recent files. However, for these changes to appear
> in LibreOffice, a new release of libetonyek must be made (and I don't know
> how to do that).
> 
> > Or, is there a workaround for this?
> If you know how to compile it, you can recompile the new libetonyek code see
> https://wiki.documentfoundation.org/DLP/Libraries/libetonyek and then
> recompile a standalone version of writerperfect see
> https://sourceforge.net/p/libwpd/wiki/writerperfect/ ...

I wonder if you were to ask on the dev list if this would help in getting it out?
Comment 9 raal 2020-06-20 17:22:54 UTC
Created attachment 162231 [details]
Apple pages document

Hello,
attached document which is blank in LO too. Tested also in latest master.
Comment 10 Frédéric MASSOT 2021-03-23 13:48:22 UTC
Hi,

The problem seems to come from the age of libetonyek.

The last released version of libetonyek (0.1.9) is from 2018 : https://git.libreoffice.org/libetonyek/+/refs/tags/libetonyek-0.1.9

This bug seems to be fixed by the developments made since 2018 : https://git.libreoffice.org/libetonyek/

Could the developers of libetonyek release a new version?


Regards.