Download it now!
Bug 123585 - Suggestion - header and footer on LibreOffice Writer
Summary: Suggestion - header and footer on LibreOffice Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2019-02-19 20:57 UTC by fagestor
Modified: 2019-05-28 08:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fagestor 2019-02-19 20:57:23 UTC
Description:
I'd like suggest a function in header and footer on LibreOffice Writer. When the user want exclude, just click on header and footer and choose EXCLUDE ALL or EXCLUDE JUST IN THIS PAGE. The same function can be applied for PAGE NUMBER. This could greatly facilitate the usability and customize page formatting.

Steps to Reproduce:
1.click on header and footer; 
2.choose EXCLUDE ALL or EXCLUDE JUST IN THIS PAGE.
1.click on page number; 
2.choose EXCLUDE ALL or EXCLUDE JUST IN THIS PAGE.


Actual Results:
Currently, there is no this function.

Expected Results:
Exclude header, footer or page number just in selected pages or in all pages.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-02-20 08:35:50 UTC
I think, it could also be an additional option to "Same content on first page" and "Same content on left and right pages" in the page style dialog (but I'm not sure, if this is feasible)
Comment 2 Regina Henschel 2019-02-20 13:34:11 UTC
We have already Insert > Header and Footer > Header with a list of all available page styles and the item 'All'. The list item has a check mark if the page style has header on. You can click on an item and toggle it. But in case you have header on in some styles and in some styles not, the item 'All' is no longer available. I can imagine to add an item 'None' to clear all at once, and to keep both 'All' and 'None' always available.

Page number is a different problem, because the page number is a field, which can not only occur in header or footer but in the body text as well.
Comment 3 Heiko Tietze 2019-02-21 11:33:56 UTC
Fabiano, what is your use case beyond the simple "remove header" functionality?
Comment 4 Heiko Tietze 2019-05-28 08:38:55 UTC
Resolving this request as WFM since the use case is not clear and comment 2 shows the how-to. Feel free to reopen with more information.