Download it now!
Bug 123596 - Can't copy selection as plain text
Summary: Can't copy selection as plain text
Status: RESOLVED DUPLICATE of bug 122689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2019-02-20 16:34 UTC by Szczepan Hołyszewski
Modified: 2019-03-14 08:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szczepan Hołyszewski 2019-02-20 16:34:55 UTC
Description:
It does not seem possible to select a range and simply copy its values as plain tab-delimited text.

Steps to Reproduce:
1. Select a range of cells
2. Press Ctrl+C
3. Launch a plaintext editor like kwrite
4. Try pasting with Ctrl+V

Actual Results:
Nothing gets pasted

Expected Results:
SOME sensible representation of the values from the selected range should be pasted; tab-separated cell values in separate lines would be the most intuitive.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 m.a.riosv 2019-02-20 21:41:28 UTC
No issue here pasting in a couple of plain text editors.
Version: 6.2.1.1 (x64)
Build ID: 757c58e8cb70b2982843211a54750fb3cd79acd5
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 2 raal 2019-02-21 20:25:30 UTC
I cannot confirm with Version: 6.3.0.0.alpha0+
Build ID: 465939feb0e9c382e5581b53b72008979ece4807
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
and gedit.
Comment 3 Roman Kuznetsov 2019-03-01 08:30:23 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: c57dc7d41bd62f933cffab6131edb7252606382d
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

I pasted data into Notepad

Szczepan, please add info about your version of LibreOffice and about your OS
Comment 4 mulla.tasanim 2019-03-13 06:21:55 UTC
Thank you for reporting the bug.
Bug is not reproducible in:


Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


I am able to copy(Ctrl+C) cell data from Calc as well as paste(Ctrl+V) data in to Notepad
Comment 5 Buovjaga 2019-03-13 17:34:19 UTC
Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Please also update to 6.2.1, if possible.
Comment 6 Szczepan Hołyszewski 2019-03-14 07:31:25 UTC
Original reporter here, not reproducing in 6.2.1 either. Seems fixed. Closing.
Comment 7 Buovjaga 2019-03-14 08:33:19 UTC

*** This bug has been marked as a duplicate of bug 122689 ***