Download it now!
Bug 123709 - Font Rendering Issue after update to 6.2.0 in both editor and GUI
Summary: Font Rendering Issue after update to 6.2.0 in both editor and GUI
Status: RESOLVED DUPLICATE of bug 124292
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-25 21:45 UTC by donaldbrown2019
Modified: 2019-03-27 22:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The Issue in writer (269.84 KB, image/png)
2019-02-25 21:46 UTC, donaldbrown2019
Details

Note You need to log in before you can comment on or make changes to this bug.
Description donaldbrown2019 2019-02-25 21:45:55 UTC
Description:
Since updating to version 6.2.0, all text in editors and menus that are part of LibreOffice has become blurry and difficult to read. As far as I can tell, this applies to all components of LibreOffice.

Steps to Reproduce:
Open LibreOffice

Actual Results:
All text renders as incredibly blurry and unreadable outside of window decorations and the "File Edit etc" bar.

Expected Results:
I expected text to render as it does normally, in a readable manner.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Help - About LibreOffice:

Version: 6.2.0.3
Build ID: 6.2.0-3
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

My Computer:

OS: Arch Linux x86_64
Host: Thinkpad T480s
Kernel: 4.20.12-arch1-1-ARCH
Resolution: 2560x1440
DE: KDE
WM: KWin
Comment 1 donaldbrown2019 2019-02-25 21:46:38 UTC
Created attachment 149586 [details]
The Issue in writer
Comment 2 Michael Weghorn 2019-03-13 08:52:00 UTC
I cannot reproduce with

Version: 6.3.0.0.alpha0+
Build ID: 73e32aff2a3b8325daf36060140878fe34c46956
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

This *might* be related to tdf#121283 which has been fixed in the meanwhile.

Could you please retest whether the issue is fixed with a newer LibreOffice version, e.g. one of the daily builds of the master branch available at [1]? [2] describes how you can install those in parallel.

[1] https://dev-builds.libreoffice.org/daily/master/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 3 Michael Weghorn 2019-03-24 22:30:24 UTC
Also, are you using a fractional scale factor, as described in bug 124292?
Comment 4 donaldbrown2019 2019-03-27 21:23:16 UTC
(In reply to Michael Weghorn from comment #3)
> Also, are you using a fractional scale factor, as described in bug 124292?

Yes, I am using a scale factor of 1.5 on my system, and now that I look at that bug, it looks exactly the same as my issue. 

As a quick update, I've tested in 2.2.2-2 and this is still the case.
Comment 5 Michael Weghorn 2019-03-27 22:30:04 UTC
Thanks for the update!

Let's mark this as a duplicate of bug 124292 then.

*** This bug has been marked as a duplicate of bug 124292 ***