Download it now!
Bug 123712 - Calc sheet with image: The image shifts when print/export to PDF in some status
Summary: Calc sheet with image: The image shifts when print/export to PDF in some status
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-02-26 03:23 UTC by Jack Lin
Modified: 2019-04-11 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
EDIT worksheet xxKDC201208 then export to PDF, AND CLOSE FILE & REPOEN IT, THEN EXPORT TO PDF AGAIN. TO SEE THE DIFFERENCE . (48.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-28 08:21 UTC, Jack Lin
Details
For reproduce the bug (308.78 KB, application/x-zip-compressed)
2019-03-08 08:54 UTC, Jack Lin
Details
Re-produce Bug#2 (700.86 KB, application/x-zip-compressed)
2019-03-19 07:01 UTC, Jack Lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Lin 2019-02-26 03:23:27 UTC
Description:
CALC SHEET WITH IMAGE, THE IMAGE SHIFTED WHEN PRINT OR EXPORT TO PDF IN SOME CONDITIONS:
1.THE CALC SHEET WITH IMAGES WAS EDITED (ANY CELL, NOT IMAGE), THEN PRINTED MORE THAN 2 SHEETS AT SAME TIME (EX: PRINT SHEET1 & SHEET2 AT THE SAME TIME), THEN IMAGE WILL SHIFTED

2.SMAE AS STEP.1 BUT PRINTED ONLY SINGE SHEET WITH IMAGE, THEN IMAGE POSITION NORMAL (NOT SHIFTED)

3. AFTER SAVE & CLOSE THE FILE, THEN RE-OPEN THE FILE, IN ANY CONDITION (MULTI-SHEET OR SINGLE SHEET) THE IMAGE POSITION WILL PRINT NORMAL (NOT SHIFFTED)

Steps to Reproduce:
1.OPEN THE FILE WITH AT LEAST 2 CALC WORKSHEETS (SHEET1 & SHEET2...)
2.Edit any worksheet with images (edit any cell, not image)
3.Print at least 2 worksheet at the same time (ex:SHEET1 & SHEET2...)

Actual Results:
The worksheet edited when printed, the image will shifted to some position.

Expected Results:
The worksheet edited when printed, the image should be the same position as screen shows.


Reproducible: Always


User Profile Reset: No



Additional Info:
1. If only print single worksheet, everything is normal.
or
2. if save and close the file. 
   then re-open the file, then everything is normal
   - print the single worksheet / multi worksheet , the image not shifted
Comment 1 raal 2019-02-27 16:07:48 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 Jack Lin 2019-02-28 08:21:26 UTC
Created attachment 149644 [details]
EDIT worksheet xxKDC201208 then export to PDF, AND  CLOSE FILE & REPOEN IT,  THEN  EXPORT TO PDF AGAIN. TO SEE THE DIFFERENCE .
Comment 3 Durgapriyanka 2019-03-06 16:48:59 UTC
Thank you for reporting the bug. I cannot reproduce the bug.

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Jack Lin 2019-03-08 08:54:43 UTC
Created attachment 149814 [details]
For reproduce the bug

1. To use Basic worksheet as active worksheet, then export to PDF(ALL PAGES, as -DoxA1-Basic.pdf ,the logo in Page5 shifts to other position)

2. To use xxKDC201208 worksheet as active worksheet, then export to PDF(ALL PAGEA, as -DoxA1-xxKDC201208.pdf ,the logo in Page5 in correct position)

3. The _DoxA1.ods was created/updated by old version of Calc, not ver.6.2
Comment 5 mulla.tasanim 2019-03-19 06:02:11 UTC
Hello Jack

Thank you for reporting the bug. 

I can not reproduce the bug in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 6 Jack Lin 2019-03-19 07:01:33 UTC
Created attachment 150091 [details]
Re-produce Bug#2

Yes, I can reproduce the bug,
Attached is the Calc file which download from bug 123712
and I use it to reproduce the bug.

Step1. Make the "BASIC" AS ACTIVE WORKSHEET, THEN EXPORT ALL PAGES TO PDF ->_DOXSTEP1.PDF (see P.5)
Step2. Make the "xxKDC201208" AS ACTIVE WORKSHEET, THEN EXPORT ALL PAGES TO PDF ->_DOXSTEP2.PDF (see P.5)
The above 2 pages are different.

For your Ref,

版本:6.2.0.3   (32 bits)
組建 ID:98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU 執行緒:3; OS:Windows 6.1; UI 算繪:預設; VCL: win;
語言地區:en-US (zh_TW); UI語言:zh-TW
Calc: threaded
Comment 7 Buovjaga 2019-04-11 19:02:40 UTC
I repro the problem in _DoxA1.ods from attachment 149814 [details] with 6.2.2, but NOT on 6.3.0.

So whatever, the problem was, it has been fixed. Let's close.

Jack can confirm with https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/

Arch Linux 64-bit
Version: 6.2.2.2
Build ID: 6.2.2-3
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 37aa4f0d64e276c46821ef6122483fb6b4c04781
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 April 2019