Bug Hunting Session
Bug 123745 - kde5: Writer: Closing "Insert" -> "Section" dialog leads to crash
Summary: kde5: Writer: Closing "Insert" -> "Section" dialog leads to crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.2
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-27 15:48 UTC by Michael Weghorn
Modified: 2019-03-13 14:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB backtrace (4.95 KB, text/plain)
2019-02-27 15:48 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2019-02-27 15:48:14 UTC
Version: 6.3.0.0.alpha0+
Build ID: d34c0852d73b1b02115cc6c469106fabd057dbb7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

1) start LibreOffice Writer
2) open dialog to insert section: "Insert" -> "Section..."
3) close the dialog using either "Cancel" or "Insert" button

Result: LibreOffice crashes

No crash occurs when using the gtk3 VCL plugin instead of the kde5 one.
Comment 1 Michael Weghorn 2019-02-27 15:48:47 UTC
Created attachment 149633 [details]
GDB backtrace
Comment 2 Vera Blagoveschenskaya 2019-03-04 07:02:07 UTC
Confirmed from my side

Version: 6.3.0.0.alpha0+
Build ID: f23738139429358c11fa62708fbdf5bb0c43d199
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-28_20:14:57
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Commit Notification 2019-03-05 12:19:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f8d98bcf37c790e4f02cbe19016b7f29f53e07ff%5E%21

tdf#123745 vcl: fix some crash in Window::SetHelpHdl()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Katarina Behrens (CIB) 2019-03-06 10:41:35 UTC
This looks like fixed
Comment 5 Michael Weghorn 2019-03-06 11:40:35 UTC
Yep. Verified with

Version: 6.3.0.0.alpha0+
Build ID: 3061ca82a323ec922dbdf2f5dcc008ade81f23a8
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Commit Notification 2019-03-12 23:05:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b8dce88a30e845ca0d496c69da9ec1b8b41522e3%5E%21

tdf#123745 vcl: fix some crash in Window::SetHelpHdl()

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-03-13 10:00:16 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-2":

https://git.libreoffice.org/core/+/a2e8e8f82449b3291c36537d92870f9c4a13ef9c%5E%21

tdf#123745 vcl: fix some crash in Window::SetHelpHdl()

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.