Bug 123750 - KDE5/ Plasma: LO Filedialog isn't showing removable devices
Summary: KDE5/ Plasma: LO Filedialog isn't showing removable devices
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.3.0 target:6.2.4 target:6.2.5
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-27 20:41 UTC by F. Tremmel
Modified: 2019-05-22 14:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice file dialog with missing removable devices (102.60 KB, image/png)
2019-02-28 18:32 UTC, F. Tremmel
Details
for comparison: kate file dialog with removable devices as last entry at the left site (129.58 KB, image/png)
2019-02-28 18:34 UTC, F. Tremmel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description F. Tremmel 2019-02-27 20:41:49 UTC
LO-filedialog isn't showing removable devices like usbsticks with VLC=kde.
This I observed since Libreoffice 6.1.x

With VLC=gtk3 removeable devices will be shown.
Comment 1 Vera Blagoveschenskaya 2019-02-28 11:59:00 UTC
Hello,

I've tried to save file to usb in LO 6.1.6.0.0+, 6.2.2.0.0+, 6.3.0.0.alpha0+
My removable device is shown correctly and I can save file on it.

Version: 6.1.6.0.0+
Build ID: 2ab2280f21fa491154e17c303dc70fcf059123b3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2019-02-13_11:49:06
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded

Version: 6.2.2.0.0+
Build ID: b17bffe4eb15e4cec969aa2699ce8be60e01b1c1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-02-25_17:41:32
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha0+
Build ID: 5413c8871dec08eff19f514f5f391b946a45c86c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-27_23:42:10
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Could you please provide us with more details?
Comment 2 F. Tremmel 2019-02-28 18:32:54 UTC
Created attachment 149663 [details]
libreoffice file dialog with missing removable devices
Comment 3 F. Tremmel 2019-02-28 18:34:55 UTC
Created attachment 149664 [details]
for comparison: kate file dialog with removable devices as last entry at the left site
Comment 4 F. Tremmel 2019-02-28 18:44:16 UTC
Version: 6.2.0.3
Build-ID: 6.2.0 Chakra GNU/Linux-3
CPU-Threads: 8; BS: Linux 4.19; UI-Render: GL; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

libreoffice --version
LibreOffice 6.2.0.3 0b127c47d9c73eec771c7eb3bb0c0ef64cd99d5f

qt5-base: 5.12.1
plasma-workspace: 5.15.1


Hello Vera
Thank you for your answer.
For me, unfortunately, no removable media appear in the file selection.
For a better understanding, I have attached two screenshots of the file selection LO and Kate.
At kate I find the usbstick as the last entry under removable media.
With LO, the entry already stops after the listing of hard disks.
Comment 5 Michael Weghorn 2019-03-04 18:09:31 UTC
Confirmed with

Version: 6.3.0.0.alpha0+
Build ID: 8643f6d64d387ebdb75b79db941d8ea1f8fa2f66
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

on Debian testing with kio at version 5.54.1-1.

Removable devices do appear when removing the call to 'QFileDialog::setSupportedSchemes()' in the 'KDE5FilePicker' constructor (file 'vcl/unx/kde5/KDE5FilePicker2.cxx').

Further investigation would be needed to find the root cause. Probably either an issue in LibreOffice or in kio.
Comment 6 Michael Weghorn 2019-04-25 16:44:21 UTC
Gerrit change: https://gerrit.libreoffice.org/#/c/71320/
Comment 7 Commit Notification 2019-04-26 14:25:36 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2c69c93fdb871809825fe8b9aff40b7afb093be8%5E%21

tdf#123750 kde5: Show removable devices in file dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-04-27 10:43:55 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c08f23b1470c0f49336c83c711d473584ce5c96f%5E%21

tdf#123750 gtk3_kde5: Show removable devices in file dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-04-28 21:00:09 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/e67f8ea50e470a7f751a9d14d9bf0213c1edd047%5E%21

tdf#123750 gtk3_kde5: Show removable devices in file dialog

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 F. Tremmel 2019-04-28 21:04:22 UTC
Michael,

Thank you for your effort and information about the progress
Comment 11 Commit Notification 2019-05-22 14:24:18 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5cd08cc0ab269556ff794ecc0de73d72b852c75a%5E%21

tdf#123750 kde5: Show removable devices in file dialog

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.