Download it now!
Bug 123776 - Items copied to clipboard in Writer are not available to other apps
Summary: Items copied to clipboard in Writer are not available to other apps
Status: RESOLVED DUPLICATE of bug 122689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-01 03:14 UTC by nivaca
Modified: 2019-03-18 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nivaca 2019-03-01 03:14:51 UTC
Description:
Althought copy/cut/paste works inside Writer, the information copied/cut is not available to other applications. 


Steps to Reproduce:
1. Copy some text in Writer.


Actual Results:
The copied item is not available to other applications in my system

Expected Results:
The copied item should be available to other applications (plain text editors, etc.)


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Manjaro Linux 4.14.102-1
KDE Plasma 5.15.1
64bits

Version: 6.2.0.3
Build ID: 6.2.0-3
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-03-01 08:46:50 UTC
Nivaca, a similar bug was recently fixed (bug 122689). So could please try to reproduce your bug with recent master? https://dev-builds.libreoffice.org/daily/master/

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 2 nivaca 2019-03-01 20:38:09 UTC
Dieter

I tested the following build:
Version: 6.3.0.0.alpha0+
Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557

The problem does *not* occur with that version.
Comment 3 Dieter 2019-03-02 11:55:34 UTC
(In reply to nivaca from comment #2)
> Dieter
> 
> I tested the following build:
> Version: 6.3.0.0.alpha0+
> Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557
> 
> The problem does *not* occur with that version.

So I think, it's a duplicate of bug 122689

*** This bug has been marked as a duplicate of bug 122689 ***
Comment 4 nivaca 2019-03-12 15:37:29 UTC
I've been testing LibreOfficeDev-6.3.0.0.alpha0_2019-02-10-x86_64.

In Writer, I can copy to the system clipboard (say, to Kate), but I CANNOT paste from the system clipboard onto Writer.
Comment 5 Dieter 2019-03-12 16:15:54 UTC
(In reply to nivaca from comment #4)
> I've been testing LibreOfficeDev-6.3.0.0.alpha0_2019-02-10-x86_64.
> 
> In Writer, I can copy to the system clipboard (say, to Kate), but I CANNOT
> paste from the system clipboard onto Writer.

Bug 122689 has been fixed on 2019-02-27. So the master you have tested with is older (as far as I can see). Can you try it with an actual version?
Comment 6 nivaca 2019-03-12 17:12:34 UTC
I can confirm that the bug is still present in the latest daily build, but only in Calc (not in Writer, Draw, or Impress). That is to say, I can copy from Calc, but not paste into Calc from the system clipboard.

Version: 6.3.0.0.alpha0+
Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557
Comment 7 Dieter 2019-03-12 20:53:27 UTC
(In reply to nivaca from comment #6)
> I can confirm that the bug is still present in the latest daily build, but
> only in Calc (not in Writer, Draw, or Impress). That is to say, I can copy
> from Calc, but not paste into Calc from the system clipboard.
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557

Regarding to the bug summary, that is about writer, I suggest to open a new bug report with this topic.
Comment 8 Michael Weghorn 2019-03-18 14:12:30 UTC
(In reply to Dieter Praas from comment #7)
> (In reply to nivaca from comment #6)
> > I can confirm that the bug is still present in the latest daily build, but
> > only in Calc (not in Writer, Draw, or Impress). That is to say, I can copy
> > from Calc, but not paste into Calc from the system clipboard.
> > 
> > Version: 6.3.0.0.alpha0+
> > Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557
> 
> Regarding to the bug summary, that is about writer, I suggest to open a new
> bug report with this topic.

Yes, let's close this one, since the originally described bug no longer occurs.

Please open a new bug report if the issue with Calc is still present, and mention explicit steps to reproduce there.
For example, I had no issues copying some text from Kate into a cell in Calc.

In particular if you're copying a large HTML table, you might be hitting bug 123115.

*** This bug has been marked as a duplicate of bug 122689 ***