Download it now!
Bug 123792 - [NEWHELP] The new SVG icons/images for math elements don't seem to make it to correct location in offline help
Summary: [NEWHELP] The new SVG icons/images for math elements don't seem to make it to...
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 125178
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2019-03-01 18:03 UTC by V Stuart Foote
Modified: 2019-06-25 12:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2019-03-01 18:03:58 UTC
On Windows 10 Ent 64-bit en-US working with Kendy's TB39 builds
Version: 6.3.0.0.alpha0+
Build ID: 5fe551931d49a64ca4ea793a5016c098e41e84cd
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

The new SVG icons/images for math elements don't seem to making it to the correct location in the offline help. 

Still seem to be using the old static/pixelated PNG icons built and placed in help/media/helpimg/starmath rather than parsing the new SVG which are being placed in help/media/icon-themes/starmath/res

Does the build path need a tweak to use the new SVG icons to build the icon cache dynamically?
Comment 1 Xisco Faulí 2019-04-16 09:10:33 UTC
Hi V Stuart Foote,
still reproducible in master ?
Comment 2 V Stuart Foote 2019-04-16 13:33:18 UTC
Still unresolved on Windows 10 64-bit en-US with TB39
Version: 6.3.0.0.alpha0+
Build ID: 25a28cee10736e8a72b40b5ab2d11dea8d5254c3
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

The static PNG icons still are being used, built and present in:

help/media/helpimg/starmath

the beautiful new SVG icons are also present, but are not being used to construct the new help pages, they are located in:

help/media/icon-themes/starmath/res

Something is just not linked up correctly to bring in the SVG icons.

Also, noticed in the Online New Help, the SVG are being used but that the glyph is not "animated" to enlarge on mouseover, and the default size is a bit to small otherwise.
Comment 3 Olivier Hallot 2019-05-08 15:30:04 UTC
> 
> Also, noticed in the Online New Help, the SVG are being used but that the
> glyph is not "animated" to enlarge on mouseover, and the default size is a
> bit to small otherwise.

reason is:

https://gerrit.libreoffice.org/plugins/gitiles/help/+/a8ab16150bf04fd812dde07bdd7d0bbd9b52f48e
Comment 4 V Stuart Foote 2019-05-08 15:48:46 UTC
(In reply to Olivier Hallot from comment #3)
> > 
> > Also, noticed in the Online New Help, the SVG are being used but that the
> > glyph is not "animated" to enlarge on mouseover, and the default size is a
> > bit to small otherwise.
> 
> reason is:
> 
> https://gerrit.libreoffice.org/plugins/gitiles/help/+/
> a8ab16150bf04fd812dde07bdd7d0bbd9b52f48e

OK, so can the now static size be increased for readability?
Comment 5 Olivier Hallot 2019-05-08 19:23:44 UTC
(In reply to V Stuart Foote from comment #4)
> (In reply to Olivier Hallot from comment #3)
> > > 
> > > Also, noticed in the Online New Help, the SVG are being used but that the
> > > glyph is not "animated" to enlarge on mouseover, and the default size is a
> > > bit to small otherwise.
> > 
> > reason is:
> > 
> > https://gerrit.libreoffice.org/plugins/gitiles/help/+/
> > a8ab16150bf04fd812dde07bdd7d0bbd9b52f48e
> 
> OK, so can the now static size be increased for readability?

Lets open a bug for that.