Bug 123829 - Line below table missing (in comparison to OpenOffice)
Summary: Line below table missing (in comparison to OpenOffice)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: odf target:6.3.0 target:6.2.3 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-04 09:34 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2019-03-06 11:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bugdoc (10.44 KB, application/vnd.oasis.opendocument.text)
2019-03-04 09:34 UTC, Samuel Mehrbrodt (allotropia)
Details
OpenOffice 3.2.1 (3.84 KB, image/png)
2019-03-04 09:34 UTC, Samuel Mehrbrodt (allotropia)
Details
LibreOffice 6.1.4 (3.69 KB, image/png)
2019-03-04 09:35 UTC, Samuel Mehrbrodt (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2019-03-04 09:34:28 UTC
Created attachment 149704 [details]
Bugdoc

OpenOffice 3.2.1 displays a line below the table, while LibreOffice 6.1.4 does not.
Comment 1 Samuel Mehrbrodt (allotropia) 2019-03-04 09:34:52 UTC
Created attachment 149706 [details]
OpenOffice 3.2.1
Comment 2 Samuel Mehrbrodt (allotropia) 2019-03-04 09:35:08 UTC
Created attachment 149707 [details]
LibreOffice 6.1.4
Comment 3 Samuel Mehrbrodt (allotropia) 2019-03-04 10:53:36 UTC
The behavior is the same in OpenOffice 3.2.1 and 4.1.6 (additional line is there).

It is also the same in LibreOffice releases from 3.3.0 to current master (additional line is *NOT* there).

Interesting fact: In LibreOffice, when you travel with the cursor out of the table, the additional line will appear. It disappears again when the cursor goes down.
Comment 4 Durgapriyanka 2019-03-04 17:05:15 UTC
Thank you for reporting the bug. I can confirm the bug is present

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Michael Stahl (allotropia) 2019-03-05 10:27:17 UTC
was presumably caused by commit 56b2cf0c10d9caa01ebae1d80465e342d046a85c "sw-collapse-empty-table-par-like-html.diff"
Comment 6 Commit Notification 2019-03-06 07:11:43 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0d2da0acfaa610c690bce552c0ed5df62d4c35cb%5E%21

tdf#123829 Respect CollapseEmptyCellPara setting when reading odf docs

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-03-06 08:31:56 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d9f94dacad1785296fffbe02e4cd56451f9db896%5E%21

tdf#123829 Respect CollapseEmptyCellPara setting when reading odf docs

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-03-06 11:33:01 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/a1ec611ea740e56949cf9f80179a90591d4f9dfc%5E%21

tdf#123829 Respect CollapseEmptyCellPara setting when reading odf docs

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.