Bug Hunting Session
Bug 123888 - creating lock file failed when FILEOPEN on exFAT-drive
Summary: creating lock file failed when FILEOPEN on exFAT-drive
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Lock
  Show dependency treegraph
 
Reported: 2019-03-05 23:05 UTC by davero
Modified: 2019-11-06 00:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davero 2019-03-05 23:05:35 UTC
Description:
Error after opening a file saved on a file partition formatted as exFAT. The lock file can't be generated so there is only read-only access of the file possible. When saving the same file e.g. on a NTFS-partition normal processing is possible. I have all the read and write rights on the exFAT partition and enough disk space available.

Steps to Reproduce:
1. save file on exFAT-drive
2. try to open that file

Actual Results:
Error message (try to translate it): The lock file for exclusive access by LibreOffice could not be created, as the rights are not sufficient to create a lock file in the save folder, or there is not enough disk space left there.

Expected Results:
read and write access possible (Surprise!)


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.0.3 (x64)
Build-ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; VCL: win; 
Gebietsschema: de-AT (de_AT); UI-Sprache: de-DE
Calc: CL
Comment 1 Julien Nabet 2019-03-06 15:19:18 UTC
On Win10 + LO 6.1.5 + exFat key, I don't reproduce this.
I created a brand odt file containing just "test", saved file, closed LO.
Then I opened the file, no error.

I did the same test with master sources (future 6.3.0) updated today.
Comment 2 Xisco Faulí 2019-04-10 12:05:25 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 3 QA Administrators 2019-10-08 02:29:07 UTC Comment hidden (obsolete)
Comment 4 davero 2019-11-05 23:25:30 UTC
Sorry for the late answer as I'm seldom in Windows.
Good news, the problem is gone without any needed action.
But I recall having troubles writing to that drive. Maybe Windows mounted it wrong... So no lock file could be created, which lead to the described problem.
Thanks Julien and Xisco for your engagement!
Comment 5 Aron Budea 2019-11-06 00:19:29 UTC
Thanks for the feedback, let's adjust status to WORKSFORME, as it's unknown what actually fixed the problem.