Bug 123920 - FILESAVE XLSX: Calc wants to retype password for protected cells when AutoRecovery execute
Summary: FILESAVE XLSX: Calc wants to retype password for protected cells when AutoRec...
Status: RESOLVED DUPLICATE of bug 123877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-07 08:42 UTC by ilike
Modified: 2019-03-08 17:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with some protected cells which causes Libreoffice Calc AutoRecovery save error (15.52 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-03-07 08:48 UTC, ilike
Details
Retype password modal window (6.23 KB, image/png)
2019-03-07 08:49 UTC, ilike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ilike 2019-03-07 08:42:37 UTC
Description:
When edit unprotected cells in spreadsheet that contains password protected items, a password prompt pops up during Autorecovery save.
The Autosave mechanism must only save changes and skip password protected items. When save the table in the usual way (Tap File - Save or press Ctrl+S) everything is fine.

Steps to Reproduce:
1. Set Tools - Options - Load/Save - General - Save AutoRecovery information every 1 minutes (for convinience)
2. Set Automatically save the document too
3. Open a XLSX sheet with protected cell and put something in any unprotected cell
6. Wait for the AutoRecovery save.

Actual Results:
When AutoRecovery is execute we get an error: 
Re-type Password
The document you are about to export has one or more protected items with password that cannot be exported. Please re-type your password to be able to export your document.

Document protection: Not protected Sheet protection: [sheet_name] Hash incompatible (Re-Type)

Expected Results:
I still think, that there is an error in the AutoRecovery save mechanism. Because if I just save the table (Tap File - Save or just press Ctrl+S) this error doesn't occur.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 ilike 2019-03-07 08:48:30 UTC
Created attachment 149781 [details]
Spreadsheet with some protected cells which causes Libreoffice Calc AutoRecovery save error
Comment 2 ilike 2019-03-07 08:49:55 UTC
Created attachment 149782 [details]
Retype password modal window
Comment 3 Oliver Brinzing 2019-03-08 17:54:41 UTC
this is a duplicate of issue

Bug 123877 - "Hash incompatible" in calc spreadsheet
(both issues have same attachment)

*** This bug has been marked as a duplicate of bug 123877 ***