Download it now!
Bug 123929 - Cannot delete a table in Impress
Summary: Cannot delete a table in Impress
Status: RESOLVED DUPLICATE of bug 78326
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2019-03-07 18:26 UTC by Levente Torok
Modified: 2019-04-18 16:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Levente Torok 2019-03-07 18:26:34 UTC
Description:
It is impossible to delete a created table in Impress.
Hitting Del doesn't work, and there is no menu entry or command for this purpose.



Steps to Reproduce:
1. Create a table
2. Select the table
3. Hit "Del"
And nothing happens.
There is no way to delete the table.

Actual Results:
Nothing happens.

Expected Results:
Table disappeared from the document being edited.


Reproducible: Always


User Profile Reset: No



Additional Info:
By drawing an object beside the table and selecting them together will allow me to delete the selection together.
Comment 1 Telesto 2019-03-07 19:40:10 UTC
Likely related to bug 117484. Table content is selected, not the table as 'object'
Comment 2 Durgapriyanka 2019-03-08 17:52:58 UTC
Thank you for reporting the bug. If I insert a table, select the table and press delete button, the table is deleted.

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 raal 2019-03-11 08:15:41 UTC
Reproduced when I select table with click into the table. Works for me when I select table with drag a selection frame around the object and then hit Del button.
How do you select a table?

Version: 6.3.0.0.alpha0+
Build ID: 732d630c3d2a168c725c18e4dd8df7a0a4f85566
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 4 Levente Torok 2019-03-11 09:56:55 UTC
Just click on the frame, this selects the table.

I wonder if only Linux based impress versions have this bug or windows versions 
have too.
Comment 5 Telesto 2019-03-11 10:33:36 UTC
(In reply to Levente Torok from comment #4)
> Just click on the frame, this selects the table.
> 
> I wonder if only Linux based impress versions have this bug or windows
> versions 
> have too.

What gets selected when clicking the table frame.. only the outer border or also the cells.. My experience: it will select the full table (not only the border), blocking deletion..

Deleting is possible for me by:
1. Clicking the table 
2. Pressing delete row in the context depended toolbar

or
1. Entering the table by clicking the cell twice (if the table is deselected)
2. Clicking the outer frame
3. Pressing delete or right click delete
Comment 6 mulla.tasanim 2019-03-29 22:45:01 UTC
*** Bug 124428 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2019-03-30 11:25:17 UTC

*** This bug has been marked as a duplicate of bug 78326 ***
Comment 8 mulla.tasanim 2019-04-18 16:51:49 UTC
*** Bug 124779 has been marked as a duplicate of this bug. ***