Download it now!
Bug 123946 - Clipboard does not work if you try to paste in Kate text editor
Summary: Clipboard does not work if you try to paste in Kate text editor
Status: RESOLVED DUPLICATE of bug 122689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Clipboard
  Show dependency treegraph
 
Reported: 2019-03-08 15:58 UTC by Luis Antonio
Modified: 2019-03-25 17:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Antonio 2019-03-08 15:58:32 UTC
Description:
Copiar y pegar de Libreoffice a Kate(editor de texto) En manjaro linux no funciona no se puede traspasar texto de kate a libreoffice ni de libreoffice a kate(editor de texto)

Actual Results:
Copiar y pegar de Libreoffice a Kate(editor de texto) En manjaro linux no funciona no se puede traspasar texto de kate a libreoffice ni de libreoffice a kate(editor de texto)

Expected Results:
Copiar y pegar de Libreoffice a Kate(editor de texto) En manjaro linux no funciona no se puede traspasar texto de kate a libreoffice ni de libreoffice a kate(editor de texto)


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2019-03-08 18:20:19 UTC
Description:
Copy and paste from Libreoffice to Kate (text editor) In Manjaro linux does not work you can not transfer text from kate to libreoffice or from libreoffice to kate (text editor)

Actual Results:
Copy and paste from Libreoffice to Kate (text editor) In Manjaro linux does not work you can not transfer text from kate to libreoffice or from libreoffice to kate (text editor)

Expected Results:
Copy and paste from Libreoffice to Kate (text editor) In Manjaro linux does not work you can not transfer text from kate to libreoffice or from libreoffice to kate (text editor)
Comment 2 mcrai 2019-03-10 10:31:36 UTC
I can confirm the copy paste issue from Writer to Kate, also from Writer to Vivaldi web browser. I did not try anything except for restart to fix the issue.

However, as of now, I CAN copy from Kate to Writer.

To me, this is critical, I have to switch to alternative OSs (Windows and Linux Mint 18.3 are fine). My preferred OS is Manjaro...

Is there anything else I can do to help?
Comment 3 Dieter 2019-03-10 16:51:49 UTC
(In reply to mcrai from comment #2)
> I can confirm the copy paste issue from Writer to Kate, also from Writer to
> Vivaldi web browser. I did not try anything except for restart to fix the
> issue.

=> set status to NEW
Comment 4 Dieter 2019-03-10 16:56:18 UTC
(In reply to mcrai from comment #2)
> Is there anything else I can do to help?

You can try to find out, if it worked in previous versions of LO. For more informations how to install different versions parallel see: https://wiki.documentfoundation.org/Installing_in_parallel
Comment 5 Xisco Faulí 2019-03-22 16:27:27 UTC
I suppose this is a KDE5 problem.

What happens if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3, does it work ?
Comment 6 Michael Weghorn 2019-03-22 23:30:20 UTC
(In reply to Xisco Faulí from comment #5)
> I suppose this is a KDE5 problem.
> 
> What happens if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3, does it
> work ?

Also, does this still happen with LibreOffice 6.2.2?
This sounds very much like bug 122689, which is fixed in version 6.2.2.
Comment 7 Xisco Faulí 2019-03-25 17:47:04 UTC
(In reply to Michael Weghorn from comment #6)
> (In reply to Xisco Faulí from comment #5)
> > I suppose this is a KDE5 problem.
> > 
> > What happens if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3, does it
> > work ?
> 
> Also, does this still happen with LibreOffice 6.2.2?
> This sounds very much like bug 122689, which is fixed in version 6.2.2.

Let's close this as RESOLVED DUPLICATED for the time being.
Luis, feel free to put it back to UNCONFIRMED if you still reproduce the issue with LibreOffice 6.2.2.2 or master

*** This bug has been marked as a duplicate of bug 122689 ***