Download it now!
Bug 123977 - SHIFT-F3 caps toggle still affects unselected text
Summary: SHIFT-F3 caps toggle still affects unselected text
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-10 14:35 UTC by medelste
Modified: 2019-03-10 15:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description medelste 2019-03-10 14:35:41 UTC
Description:
This is a repeat report of an existing bug.

SHIFT-F3 is used to toggle capitalization of selected text.  This feature is very useful for screenwriting and other tasks.  A recent release changed this function so that the entire sentence is affected rather than just the selected text.  The newest release still does this.

I've seen the ongoing debate about this functionality in LO.  However it's my opinion that when a user selects text in a software program, any subsequent operations should ONLY affect that selection.  If I want the entire sentence changed, the user will select the entire sentence.

Thanks

Steps to Reproduce:
1.Type a sentence with varying capitalization, such as "My favorite NFL team is the Arizona Cardinals."
2. Select "Arizona Cardinals" text.
3. Type SHIFT-F3 multiple times.

Actual Results:
Along with "Arizona Cardinals", the unselected text NFL is changed to lower case.

Expected Results:
Only the text "Arizona Cardinals" should be affected.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 V Stuart Foote 2019-03-10 15:51:11 UTC

*** This bug has been marked as a duplicate of bug 49033 ***