Download it now!
Bug 123979 - File marked as "modified" after printing
Summary: File marked as "modified" after printing
Status: RESOLVED DUPLICATE of bug 123378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ModifiedStatus
  Show dependency treegraph
 
Reported: 2019-03-10 15:32 UTC by Wolfgang Denk
Modified: 2019-03-13 14:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Denk 2019-03-10 15:32:21 UTC
When I save a file and then print it, it is maked as "modified", and when I try to close it, it prompts to "Save changes to document...".

This also happens when printing (as PDF) to a file.

However, it does NOT mark a file as changed when exporting it as PDF.

This is at least inconsequent and unexpected behaviour.

In general, I think it is wrong to consider a file has changed just when I printed it - it causes all kinds of trouble.  For example, assume you just want to print an existing document which has fields "DocInformation" -> "Modified" -> "date" or "Time".  Then savin the file would actually MODIFY it, thus overwriting the proginal file even if you only wanted to print another copy of it.
Comment 1 V Stuart Foote 2019-03-10 15:44:59 UTC
Please verify status of the checkbox/radiobutton control Tools -> Options -> General: Document Status 'Printing sets "document modified" status'

If it is unchecked and the status is showing as changed--*then* it is an implementation error. If checked? Uncheck and retest.
Comment 2 Wolfgang Denk 2019-03-10 15:56:51 UTC
(In reply to V Stuart Foote from comment #1)
> Please verify status of the checkbox/radiobutton control Tools -> Options ->
> General: Document Status 'Printing sets "document modified" status'
> 
> If it is unchecked and the status is showing as changed--*then* it is an
> implementation error. If checked? Uncheck and retest.

It is unchecked.
Comment 3 Oliver Brinzing 2019-03-10 18:52:39 UTC
(In reply to Wolfgang Denk from comment #0)
> When I save a file and then print it, it is maked as "modified", and when I
> try to close it, it prompts to "Save changes to document...".
> This also happens when printing (as PDF) to a file.

i can not confirm this behaviour (Document Status 'Printing sets "document modified" status' is unchecked) with:

Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

Linux only, or maybe a problem with user profile?
Comment 4 Wolfgang Denk 2019-03-10 19:29:05 UTC
(In reply to Oliver Brinzing from comment #3)
> 
> i can not confirm this behaviour (Document Status 'Printing sets "document
> modified" status' is unchecked) with:
> 
> Version: 6.1.5.2 (x64)
> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
> CPU threads: 4; OS: Windows 10.0; UI render: default; 
> Locale: de-DE (de_DE); Calc: 
> 
> Linux only, or maybe a problem with user profile?

Version: 6.1.5.2
Build ID: 6.1.5.2-1.fc29
CPU threads: 12; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.utf8); Calc: group threaded

It may well be a problem under Linux only. I don't think it's user
profile related - I've tested it under another user account on a
fresh install of Fedora 29, and the problem is there, too [my own
setup has been in use over many years, migrated from version to
version, so there _could_ be obsolete settings].
Comment 5 Wolfgang Denk 2019-03-12 16:55:45 UTC
I justed tested an older version - 6.1.4.2; the problemis _not_ present there, so it must be one of the changes between 6.1.4.2 and 6.1.5.2 ...
Comment 6 Aron Budea 2019-03-13 14:31:01 UTC
I'd assume this is bug 123378, please see bug 123378 comment 10

*** This bug has been marked as a duplicate of bug 123378 ***