Bug 123984 - Bad scaling of inserted video in Impress
Summary: Bad scaling of inserted video in Impress
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Show Media
  Show dependency treegraph
 
Reported: 2019-03-10 19:31 UTC by Petr Valach
Modified: 2019-05-08 19:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
About LibreOffice (53.79 KB, image/png)
2019-03-10 19:32 UTC, Petr Valach
Details
presentation (14.95 MB, application/zip)
2019-05-08 19:51 UTC, Petr Valach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Valach 2019-03-10 19:31:25 UTC
Description:
Video inserted into presentation has bad scaling during presenting.

Steps to Reproduce:
1. Open Impress application
2. Create new presentation
3. Insert video file into slide
4. Change its scale (video must be smaller than slide)
5. Play presentation

Actual Results:
Video scales into whole slide.

Expected Results:
Video keeps its scale.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
It occur in 6.2.0 and 6.2.1. Not in older version.
I use Linux Mint 19.1.
Comment 1 Petr Valach 2019-03-10 19:32:54 UTC
Created attachment 149866 [details]
About LibreOffice
Comment 2 Xisco Faulí 2019-04-16 09:03:18 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 Petr Valach 2019-05-08 19:51:32 UTC
Created attachment 151251 [details]
presentation

I posted presentation with one of video file. The bug can be solved by installing package gstreamer1.0-gtk3.