Bug Hunting Session
Bug 124028 - Dialog to choose a font does not work anymore
Summary: Dialog to choose a font does not work anymore
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.3 target:6.2.2
Keywords: bibisected, bisected, regression
: 124216 (view as bug list)
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2019-03-12 16:02 UTC by Jean-Baptiste Faure
Modified: 2019-03-20 17:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2019-03-12 16:02:06 UTC
Description:
In the formula editor it is not possible to change a font in the font dialog because Help, Cancel and OK buttons do nothing.

Steps to Reproduce:
1. open a blank new Math document
2. menu Format > Fonts
3. in the dialog which appears, click the button "Modify" and choose an item
4. in the dialog which appears, choose a font and click the OK or the Cancel button

Actual Results:
Clicking one of the three buttons (Help, Cancel or OK) does nothing

Expected Results:
Each button does what it should


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Same problem in the master.
It works as expected in LO 6.1.x so it is a regression

Version: 6.2.3.0.0+
Build ID: 20726c61680242eb647253651302dc048348687d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Aron Budea 2019-03-12 17:44:36 UTC
Confirmed, and bibisected to the following commit using repo bibisect-linux-64-6.3. Adding Cc: to Caolán McNamara, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ab8e0f5832fa910f8b1abd36d7cb3929cbac2395
author		Caolán McNamara <caolanm@redhat.com>	2019-01-18 17:08:58 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-01-21 16:32:19 +0100

Resolves: tdf#122484 replace gtk autocomplete with vcl-alike autoselect
Comment 2 Caolán McNamara 2019-03-13 16:40:03 UTC
That's a weird sideeffect of dangling references to those removed autocomplete entries. https://gerrit.libreoffice.org/#/c/69210/ fixes it
Comment 3 Commit Notification 2019-03-13 21:18:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/68bae22d127986875fab6e715b0fe53280a499ec%5E%21

Resolves: tdf#124028 dangling "completion" entries block responses

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2019-03-13 21:43:20 UTC
fixed in master, backports in gerrit
Comment 5 Commit Notification 2019-03-14 09:03:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/e9a3be4d95834b056557cd166bdb1ce3cd857cfb%5E%21

Resolves: tdf#124028 dangling "completion" entries block responses

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-03-14 09:36:37 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: c196d70337f6b755cfc4c34beda05554c6fab114
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 7 Jean-Baptiste Faure 2019-03-14 10:21:20 UTC
Verified in Version: 6.2.3.0.0+
Build ID: f0b71fafd3a2fd6158c5952d601092179cba21e5
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Thank you very much for the quick resolution of this regression.

Best regards. JBF
Comment 8 Commit Notification 2019-03-15 09:02:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-2":

https://git.libreoffice.org/core/+/a2f06dcf8ad41ad94c309e7e79e8000842760d7e%5E%21

Resolves: tdf#124028 dangling "completion" entries block responses

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-03-20 17:43:57 UTC
*** Bug 124216 has been marked as a duplicate of this bug. ***