Download it now!
Bug 124030 - libreoffice crashes, when selecting a MTRANS generated range
Summary: libreoffice crashes, when selecting a MTRANS generated range
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Selection
  Show dependency treegraph
 
Reported: 2019-03-12 17:19 UTC by NoRa
Modified: 2019-03-21 09:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with MTRANS (9.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-03-12 17:20 UTC, NoRa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NoRa 2019-03-12 17:19:34 UTC
Description:
An automatically transformed area is to be generated from a table with a value range using MTRANS. The creation with the function is correct. Libreoffice crashes when trying to select the range created with MTRANS.

Steps to Reproduce:
1.load the attached file
2.Go to cell B12
3.Try to select the MTRANS table by using CTRL-SHIFT-LEFT or try to select the complete column B by clicking on the row name

Actual Results:
Libreoffice crashes

Expected Results:
Selecting the range of fields


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This error also comes with the appimage version

OS-actual Manjaro with all updates
Comment 1 NoRa 2019-03-12 17:20:35 UTC
Created attachment 149920 [details]
Example file with MTRANS
Comment 2 m.a.riosv 2019-03-12 22:15:51 UTC
No issue with
Version: 6.2.2.1 (x64)
Build ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded

I think there was a solved bug not to much time ago.
Comment 3 Roman Kuznetsov 2019-03-13 10:35:53 UTC
don't repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 13a260f59e421f3e67845f8f2eb22b8f0f8fcaf0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-11_02:46:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Linux only?
Comment 4 NoRa 2019-03-13 16:55:06 UTC
Yes, Linux only.

I've tested it under Win 10 and everything was ok.
Comment 5 Xisco Faulí 2019-03-13 18:19:38 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 8aa579830b20072af8d6e149d6b279362fe98b91
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 NoRa 2019-03-14 19:17:59 UTC
Hi,

Testing with the daily appimage 6.3.0.0 the bug is still present.

Version 6.1.5 works fine.

Linux heim 4.19.28-1-MANJARO #1 SMP PREEMPT Sun Mar 10 08:32:42 UTC 2019 x86_64 GNU/Linux
Comment 7 NoRa 2019-03-15 17:19:47 UTC
OK,

I think it's a spezial problem under Manjaro or Arch Linux.

Running LO 6.2 under Ubuntu-live has no error at this point.
Comment 8 Xisco Faulí 2019-03-18 19:21:55 UTC
(In reply to NoRa from comment #7)
> OK,
> 
> I think it's a spezial problem under Manjaro or Arch Linux.
> 
> Running LO 6.2 under Ubuntu-live has no error at this point.

Hi Nora,
please follow the instructions provided at this link < https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux >. and submit a backtrace. That way a developer can look into the underlying reason of the crash.
Comment 9 NoRa 2019-03-19 18:38:39 UTC
Hi,

I'm sorry.

I've loaded the last daily build LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_archive. I can't reproduce the error with this version.

With version
Version: 6.2.1.2
Build-ID: 6.2.1-1
CPU-Threads: 8; BS: Linux 4.19; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

I got this error prompt:

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1266, resource id: 25166447, major code: 40 (TranslateCoords), minor code: 0

So forget it, the bug will be solved in 6.3.

Thanks
Comment 10 Xisco Faulí 2019-03-20 09:42:32 UTC
(In reply to NoRa from comment #6)
> Hi,
> 
> Testing with the daily appimage 6.3.0.0 the bug is still present.
> 
> Version 6.1.5 works fine.
> 
> Linux heim 4.19.28-1-MANJARO #1 SMP PREEMPT Sun Mar 10 08:32:42 UTC 2019
> x86_64 GNU/Linux

On the one hand, you can reproduce it with a appimage 6.3, but you can't with LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_archive.

Appimage bug ?
Comment 11 NoRa 2019-03-20 17:21:50 UTC
Hi, I'm sorry but so it is.

I've tested it oncemore. The appimage crashes and the installed daily buid not.

I've tested also version 6.2.1.2 from rpm packages built via libreoffice-dev-bin from AUR and it crashes. 
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
also built from AUR don't crash - great.

I don't know where I can look now. I will wait, it seems the bug will be fix in the next version.
Comment 12 Xisco Faulí 2019-03-21 09:37:08 UTC
(In reply to NoRa from comment #11)
> Hi, I'm sorry but so it is.
> 
> I've tested it oncemore. The appimage crashes and the installed daily buid
> not.
> 
> I've tested also version 6.2.1.2 from rpm packages built via
> libreoffice-dev-bin from AUR and it crashes. 
> Version: 6.2.2.2
> Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
> CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
> Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
> Calc: threaded
> also built from AUR don't crash - great.
> 
> I don't know where I can look now. I will wait, it seems the bug will be fix
> in the next version.

I would say it was a KDE5 crash. Anyway, since it's no longer reproducible in 6.2.2.2, it's problably fixed by one of the fixes for KDE5 in that version. Check the release notes -> https://wiki.documentfoundation.org/Releases/6.2.2/RC1 and 
https://wiki.documentfoundation.org/Releases/6.2.2/RC2
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.