Download it now!
Bug 124033 - Cannot paste into Calc from system clipboard
Summary: Cannot paste into Calc from system clipboard
Status: RESOLVED DUPLICATE of bug 122689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-03-12 21:01 UTC by nivaca
Modified: 2019-03-16 17:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nivaca 2019-03-12 21:01:42 UTC
Description:
I cannot paste from the system clipboard into Calc (although I can copy from Calc into the system clipboard).



Steps to Reproduce:
1. Open a text editor (e.g. Kate) can copy some text from it into the system clipboard.
2. Try to paste into Calc.


Actual Results:
Doesn't paste into Calc.

Expected Results:
Contents are actually pasted into Calc.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument

Version: 6.2.1.2
Build ID: 6.2.1-1
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded


** NOTE **
I also tried this with the latest daily release (Version: 6.3.0.0.alpha0+,  Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557) and can confirm that the problem subsists.
Comment 1 mulla.tasanim 2019-03-13 06:23:49 UTC
Thank you for reporting the bug.
Bug is not reproducible in:


Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


I am able to copy(Ctrl+C) data from Text Editor(Notepad) as well as paste(Ctrl+V) data in to Cells of Calc
Comment 2 Buovjaga 2019-03-13 17:47:07 UTC
Works for me here running KDE Plasma.

What Linux distro are you running?
Do you have any clipboard managers running? If Klipper: right-click System Tray, settings > General > Extra Items. Uncheck "Clipboard"

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: adb08e892b37ea9e155abbdee4e0c9951a1d163b
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 12 March 2019

Arch Linux 64-bit
Version: 6.2.1.2
Build ID: 6.2.1-1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 nivaca 2019-03-13 18:50:50 UTC
No Klipper running. Bug persists.

Operating System: Manjaro Linux 
KDE Plasma Version: 5.15.2
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.1
Kernel Version: 4.19.28-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15,4 GiB of RAM
Comment 4 Michael Weghorn 2019-03-16 00:10:41 UTC
This sounds like bug 122689 in which case this is fixed in LibreOffice 6.2.2.
Does copying work just after starting LibreOffice (i.e. before you ever copy anything to the clipboard from inside LibreOffice)?
Comment 5 nivaca 2019-03-16 03:22:48 UTC
Yes, just after I start Calc, pasting from system clipboard to Calc works all right.
But the moment I copy something from Calc, the clipboard gets locked, as I described in my bug post.
Comment 6 Buovjaga 2019-03-16 07:19:20 UTC
(In reply to Michael Weghorn from comment #4)
> This sounds like bug 122689 in which case this is fixed in LibreOffice 6.2.2.
> Does copying work just after starting LibreOffice (i.e. before you ever copy
> anything to the clipboard from inside LibreOffice)?

I couldn't repro with 6.2.1, though, which is odd.
Comment 7 Michael Weghorn 2019-03-16 17:20:27 UTC
(In reply to nivaca from comment #5)
> Yes, just after I start Calc, pasting from system clipboard to Calc works
> all right.
> But the moment I copy something from Calc, the clipboard gets locked, as I
> described in my bug post.

Thanks for testing. This really seems to be the same as bug 122689 then, so I'll close this one here as a duplicate.
Please reopen if the bug still appears with either a daily build of LibreOffice 6.2 available at [1] or with LibreOffice 6.2.2, which is supposed to be released next week.

(In reply to Buovjaga from comment #6)
> I couldn't repro with 6.2.1, though, which is odd.

That's really odd then...


[1] https://dev-builds.libreoffice.org/daily/libreoffice-6-2/

*** This bug has been marked as a duplicate of bug 122689 ***