Download it now!
Bug 124035 - LibreLogo: lost support of starting colon in variable names
Summary: LibreLogo: lost support of starting colon in variable names
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: regression
Depends on:
Blocks: LibreLogo
  Show dependency treegraph
 
Reported: 2019-03-12 22:14 UTC by László Németh
Modified: 2019-03-14 15:38 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2019-03-12 22:14:59 UTC
For example, compiling this program shows problem in the line "PRINT :n", but removing the colons, the program runs correctly.

TO example :n
PRINT :n
END

example 123
Comment 1 László Németh 2019-03-12 22:17:29 UTC
The problem was reported by Ferenc Salánki.
Comment 2 Commit Notification 2019-03-13 06:42:04 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8547a8d90af69104f4eb27137d39678b45d6d9d1%5E%21

tdf#124035 LibreLogo: support starting colon in variable names

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2019-03-14 15:38:29 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d2e3b661d6bc0c24b79abacee50329e4bff3ec88%5E%21

tdf#124035 LibreLogo: support starting colon in variable names

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.