Download it now!
Bug 124043 - Java Runtime Error in LanguageTool 3.6
Summary: Java Runtime Error in LanguageTool 3.6
Status: RESOLVED DUPLICATE of bug 75051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-13 07:58 UTC by Jan Sepp
Modified: 2019-03-13 13:27 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot with Java errors in languagetool (58.45 KB, image/png)
2019-03-13 07:58 UTC, Jan Sepp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Sepp 2019-03-13 07:58:54 UTC
Created attachment 149925 [details]
screenshot with Java errors in languagetool

Good morning,

I just installed Linux Mint 19.1 with LibreOffice 6.0.7.3 included, on my PC. Of course I did an update after that, so I should be reasonably up to date. Every time I open LibreOffice I get two Java errors, both in LanguageTool. The first starts with:"Java.lang.NoClassDefFoundError: java/XML/bind/JAXBException" and the second starts with "Java.lang.NoClassDefFoundError: could not initialize class org.languagetoo.Languages"

I add a screenshot.

I can live without languagetool (I think, what does it really do?) so no hurrry. Just because someone should bring this to your attention.

Thank you very much,

Jan Sepp
Comment 1 Alex Thurgood 2019-03-13 09:05:16 UTC
@Jan : the language tool extension is not installed by default, so you must have installed it yourself, for example, via an extra packet or downloading it from the extensions site.

If you installed this as a packet provided by Mint, then you should file a bug report with them.

If you installed this as an extension from the extensions website, then you should contact the author of the extension from the website.

As far as I can tell, this is a very similar, if not duplicate, report to bug 75051 (which concerned macOS, but the error you are reporting is the same).

The workaround is indicated in :

https://bugs.documentfoundation.org/show_bug.cgi?id=75051#c20

*** This bug has been marked as a duplicate of bug 75051 ***
Comment 2 Alex Thurgood 2019-03-13 09:06:16 UTC
Please see https://forum.languagetool.org/t/lt-and-java-9/1588 for information about LT and Java 9.
Comment 3 Jan Sepp 2019-03-13 13:27:21 UTC
Thank you, Alex. Sorry to have bothered you. Regards, Jan