Bug 124045 - Saving to PDF/A produces distorted images with OpenGL activated
Summary: Saving to PDF/A produces distorted images with OpenGL activated
Status: RESOLVED DUPLICATE of bug 121615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-03-13 09:56 UTC by luca.manganelli
Modified: 2019-03-28 13:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luca.manganelli 2019-03-13 09:56:38 UTC
Description:
Hi, using LibreOffice 6.1.5 STILL, when I save to PDF/A, the new file generated has distorted images, only when OpenGL is activated on Windows 10.

This does NOT occur if:

 - I save to plain PDF;
 - The operating system is Windows 7 (the problem occurs in Windows 10);
 - I have disabled JPEG Compression (using the loseless mode)

All systems have Intel graphics.

Steps to Reproduce:
ONLY in windows 10:

1. Export document to PDF
2. Choose JPEG Compression and PDF/A format
3. Save it

Actual Results:
I have a PDF/A with distorted images.

Expected Results:
Having PDF/A with correctly scaled images.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 luca.manganelli 2019-03-13 09:58:43 UTC
OpenGL enabled: Yes
Comment 2 Roman Kuznetsov 2019-03-14 20:29:19 UTC
(In reply to luca.manganelli from comment #1)
> OpenGL enabled: Yes

and If you disable OpenGL, then you have a problem with image in PDF?
Comment 3 luca.manganelli 2019-03-15 06:58:54 UTC
(In reply to Roman Kuznetsov from comment #2)
> and If you disable OpenGL, then you have a problem with image in PDF?

No: it occurs only when I enable OpenGL and only with PDF/A format.
Comment 4 Xisco Faulí 2019-03-28 13:56:13 UTC
it seems like a duplicate of bug 121615 which is fixed in LibreOffice 6.2.3 and 6.1.6. They will be available soon. stay tuned

*** This bug has been marked as a duplicate of bug 121615 ***