Bug 124056 - Borders missing on objects
Summary: Borders missing on objects
Status: RESOLVED DUPLICATE of bug 121241
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 124071 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-13 12:57 UTC by liljjpoppins
Modified: 2019-03-14 20:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Image showing the border specified for a table in the Table Properties windows vs the borders on the actual table above the window (501.93 KB, image/png)
2019-03-13 12:58 UTC, liljjpoppins
Details
Examples of shapes (13.38 KB, application/vnd.oasis.opendocument.graphics)
2019-03-14 12:08 UTC, dhina
Details
Examples of shapes - what it should look like (11.62 KB, application/pdf)
2019-03-14 12:09 UTC, dhina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liljjpoppins 2019-03-13 12:57:06 UTC
Description:
On macOs Mojave, when creating a table, the borders on a table are completely absent. Even after you specify a border, it still won't show any changes on the table itself, despite the properties of the table clearly suggesting the border is set.

If you save the document, close it and open it with Apache OpenOffice it will become evident the border is in fact set.

The problem is not exclusive to tables however, but on every single object on which you can specify a border (shapes, tables, frames, etc. …). The problem is absent on cells in a spreadsheet.

This problem doesn't occur on Windows.

Steps to Reproduce:
1. Insert a table, shape, or frame.
2. Give it a border.

Actual Results:
The object has a border which is hardly visible.

Expected Results:
The object has a border you can see with the style you chose for it.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 liljjpoppins 2019-03-13 12:58:49 UTC
Created attachment 149935 [details]
Image showing the border specified for a table in the Table Properties windows vs the borders on the actual table above the window
Comment 2 dhina 2019-03-14 12:03:34 UTC
*** Bug 124071 has been marked as a duplicate of this bug. ***
Comment 3 dhina 2019-03-14 12:07:29 UTC
I have the same issue on Mac OSX



Some additional information:

- All the lines (tables, arrows, shapes)  disappear ONLY if the display zoom is not great enough while editing the documents. 

- It happens whatever the line width, but the wider the line is, the smaller the zoom should be to make the lines disappear.

- The PDF export is not affected.



Steps to Reproduce:
1. Open my document exemple
2. Zoom to see all the objects
3. Unzoom untill the lines disapear

Actual Results:
The lines disappear

Expected Results:
The lines shoul not disappear


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: GL; VCL: osx; 
Locale: en-GB (en_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 dhina 2019-03-14 12:08:35 UTC
Created attachment 149961 [details]
Examples of shapes
Comment 5 dhina 2019-03-14 12:09:10 UTC
Created attachment 149962 [details]
Examples of shapes - what it should look like
Comment 6 Xisco Faulí 2019-03-14 20:55:28 UTC
Hello,
this is a duplicate of bug 121241

*** This bug has been marked as a duplicate of bug 121241 ***