Bug 124063 - Feature Request: Per-document dictionary
Summary: Feature Request: Per-document dictionary
Status: RESOLVED DUPLICATE of bug 90007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2019-03-13 18:15 UTC by huynhdequan02
Modified: 2019-03-13 19:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description huynhdequan02 2019-03-13 18:15:05 UTC
Description:
Q: What?
A: A dictionary for that document only.

Q: Why?
A: Add some specific word, like company name or technical term, to the dictionary would help Spelling to highlight only real mistake.

Q: How?
A: I'm not sure, I'm new here.

Steps to Reproduce:
1. Type something that not in the current dictionary.
2. Expect the red-underlined indicating that it is not in the dictionary.
3. Right click on the red-underlined word.

Actual Results:
Show the "Add to dictionary" option. If choose this, the selected word will not be red-underlined in this document and in another document.

Expected Results:
Show the "Add to global dictionary" and the "Add to this document dictionary" option. If choose "Add to global dictionary" then the selected word will not be red-underlined in this document and in another document. If choose "Add to this document dictionary" then the selected word will not be red-underlined in this document but will be red-underlined in another document as usuall.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 1 Dieter Praas 2019-03-13 19:43:59 UTC
You can create a new dictionary for a docment: Tools => Spelling => Options => New. You can add a word to that dictionary when you put cursor in the word and open context menu.

What remains is to associate that dictionry with a document. That's bug 90007.

*** This bug has been marked as a duplicate of bug 90007 ***