Bug Hunting Session
Bug 124068 - Impress embeded videos are broken in "GTK3" VCL
Summary: Impress embeded videos are broken in "GTK3" VCL
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media
  Show dependency treegraph
 
Reported: 2019-03-14 08:43 UTC by Gašper Sedej
Modified: 2019-03-14 20:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gašper Sedej 2019-03-14 08:43:13 UTC
Description:
When embeding videos in Impress presentation when vcl "gtk3" is used

The video is displayed in fullscreen and on both monitors (when in presentation) and over full window when in edit mode and video play butoon is pressed.

This broken behavior is not present in "gtk2" mode. The GTK3 is default in new Ubuntu versions (e.g. 18.04 and 18.10). I have already contacted packaging team.

The bug is present in LO 6.0.?, 6.1.x and 6.2.1.1 (I am not sure what are exact older versions I tested)

I made video on this issue: https://youtu.be/77E6IzVJ5jA

I also opened this reddit tred: https://www.reddit.com/r/libreoffice/comments/b0jrdn/impress_embed_video_always_plays_fullscreen/


I tested: composition ("opengl") does not play role here (bug is present if OFF or ON)

Steps to Reproduce:
1. open impress in Ubuntu 18.04 or 18.10
2. embed any video in it
3. press F5 or "play button

Actual Results:
Video playback in in fullscreen and video is tearing. Also in both screens when presentation

Expected Results:
Vide should be played in the designated location and size inside slide


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.1.1
Build ID: 1:6.2.1~rc1-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk2; 
Locale: sl-SI (sl_SI.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Caolán McNamara 2019-03-14 08:55:14 UTC
probably missing the gstreamer gtksink plugin on your machine (which works great, so install that if you can, package gstreamer1-plugins-good-gtk in fedora f.e), so its falling back to the non-gtksink implementation. I think Mark was making improvements to that fallback recently
Comment 2 Gašper Sedej 2019-03-14 09:12:59 UTC
Thanks for reply. The installing package "gstreamer1.0-gtk3" in ubuntu 18.04 did help. It's working now.

What can be done? I have the the "LibreOffice Packaging team" via "Contact admins", but I can find how to add additional info (solution for gtk3 gsteamer)
Comment 3 Mark Hung 2019-03-14 10:59:56 UTC
Hi, 

That should have been fixed by the following commit.

commit 18138417485aeba6c52d935c616dba829b24ffd8
Author: Mark Hung <marklh9@gmail.com>
Date:   Mon Feb 18 21:51:57 2019 +0800

    avmedia: set gstreamer gst_video_overlay size and position.

    Have video fit to the media object size on the slide,
    allow more complicated interactions.

    Change-Id: Ice1fa4b521176ad7ed7f7d1d2b13e617e8282390
    Reviewed-on: https://gerrit.libreoffice.org/67978
    Tested-by: Jenkins
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
    Tested-by: Caolán McNamara <caolanm@redhat.com>



It should already be available in daily build.
Comment 4 Gašper Sedej 2019-03-14 11:08:57 UTC
Thanks for reply. 

Though I am not sure about the fix. My LO 6.2.1.1 already works fine when installing package "gstreamer1.0-gtk3" on ubuntu. What I understand, my bug report is actually packaging problem - missing dependency. Does commit 18138417485aeba6c52d935c616dba829b24ffd8 fix the missing package (e.g. gstreamer1.0-gtk3 is not needed)?
Comment 5 bordfeldt 2019-03-14 12:35:36 UTC
For me the same problem as Gasper described. My system: LO 6.1.5.2 on Ubuntu 18.04.
After installing gstreamer1.0-gtk3 the problem is solved.
Comment 6 Roman Kuznetsov 2019-03-14 20:16:03 UTC
Close as WFM after comment 4 and comment 5