Bug 124080 - System freezes after search using autofilter
Summary: System freezes after search using autofilter
Status: RESOLVED DUPLICATE of bug 76481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Data-Filter XLSX-Autofilter
  Show dependency treegraph
 
Reported: 2019-03-14 14:52 UTC by Daniel
Modified: 2020-05-18 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File that generate the problem (1.51 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-03-15 21:11 UTC, Daniel
Details
Video showing the problem (4.46 MB, video/x-matroska)
2019-03-15 21:58 UTC, Daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2019-03-14 14:52:03 UTC
Description:
Hi
When I use autofilter in order to find a text, The  system freezes and I can't write any character for many seconds (30 sec aprox) into textbox filter

Steps to Reproduce:
1.Download https://administracionelectronica.gob.es/ctt/resources/Soluciones/238/Descargas/Listado%20Unidades%20AGE.xlsx?idIniciativa=238&idElemento=2741
2. Pick on "C_DNM_UD_ORGANICA" filter
3. Try to search by text

Actual Results:
System freezes

Expected Results:
Filter correctly


Reproducible: Always


User Profile Reset: No



Additional Info:
Video showing the problem in this link: https://www.dropbox.com/s/v944kliwz58hj4g/vokoscreen-2019-03-14_15-46-55.mkv?dl=0
Comment 1 Roman Kuznetsov 2019-03-15 20:04:41 UTC
Can't download a file by link from description.

Daniel, please attach file directly into bug
Comment 2 Daniel 2019-03-15 21:11:45 UTC
Created attachment 150009 [details]
File that generate the problem
Comment 3 Daniel 2019-03-15 21:12:07 UTC
File uploaded!
Comment 4 Daniel 2019-03-15 21:58:27 UTC
Created attachment 150011 [details]
Video showing the problem
Comment 5 Oliver Brinzing 2019-03-16 12:57:16 UTC
i can confirm this with:

Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

LO freezes for ~45s on my notebook (Win10Pro x64, Core-i5-3320M 2,6GHZ,8GB,256GB SSD) and settings:
- OpenGL/OpenCL:             disabled 
- CPU threading settings:    disabled

steps to reproduce
- open attached file
- open autofilter column C
- enter "Zona" into "Search items..." field
Comment 6 Oliver Brinzing 2019-03-16 13:08:02 UTC
already reproducible with:

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: single
Comment 7 b. 2020-03-23 12:44:36 UTC
most likely the same issue as in bug #76481 ... and many duplicates, 

looks independent of file format (.ods or .xlsx), 

actually not a bug that i consider dramatic, 

but it's a doubtful practice to get bugs dragged away over years by disqualifying new messages or findings as 'duplicate' from old bugs and thus 'resolved' ... while nobody cares about the old still unsolved bugs ('we have been living with it for so long', 'the program is usable at all', 'surely many have tried and failed', 'the threads are much too long and contradictory', 'who is going to read all this stuff', and the old versions that don't have the bugs in them yet are much too old to compare against actual versions to pin down the bugs ...) 

i think LO and the bugtracker need a better handling of 'old bugs', maybe prioritizing of bugs that last longer than 12 months, maybe hints in the program, in 'ask' or at least in 'bugs' 'this and that' is not solvable for certain reasons, mark problematic options as experimental or whatever ...
Comment 8 b. 2020-05-18 20:28:56 UTC
less data, less dramatic, but dup. of #76481

*** This bug has been marked as a duplicate of bug 76481 ***