Bug Hunting Session
Bug 124110 - LO 6.2 does not start at all under Linux + KDE
Summary: LO 6.2 does not start at all under Linux + KDE
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-15 21:04 UTC by Robert Cabane
Modified: 2019-04-23 18:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cabane 2019-03-15 21:04:30 UTC
Description:
I'm using OpenSUSE with the KDE desktop (KF5.45 - Qt 5.9.4).
As I downloaded LO 6.2.0, I was surprised by the fact that it could'nt start (just showing the splash image, nothing more). I waited until LO 6.2.1 was published, nothing changed.

Steps to Reproduce:
1. Have a system OpenSUSE 15.0 + KDE5
2. Launch libreoffice and watch.

Actual Results:
Splash image shown, and nothing more.
When launched from the console with -v switch, nothing more appears.

Expected Results:
Main application screen.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I tried launching LO 6.2 with -v --save-mode switches.
The following error message is then obtained :
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'
Comment 1 Robert Cabane 2019-03-15 21:06:43 UTC
I also tried to launch LO62 this way :
SAL_USE_VCLPLUGIN=gen /opt/libreoffice6.2/program/soffice -v --safe-mode
with exactly the same result.
Comment 2 Robert Cabane 2019-03-15 21:07:50 UTC
Additional info : this bug could be close, or  related, to 
https://bugs.documentfoundation.org/show_bug.cgi?id=123232
Comment 3 Michael Weghorn 2019-03-16 00:17:53 UTC
First: Thanks for creating a separate bug report!

Can you try whether this also happens with a current daily build of master? You can download that from [1] and install it in parallel to your existing LibreOffice version as described at [2].

Also: Do you have any additional extensions etc. installed?

Please set the bug status back to UNCONFIRMED if you can still reproduce there.


[1] https://dev-builds.libreoffice.org/daily/master/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 4 Robert Cabane 2019-03-16 14:45:12 UTC
Good news. I've just installed LO 6.3.0.0.alpha0 (daily build 2019-03-14). Starting right away under my system, no problem at all.

What could I do, so that this problem could be solved in a near future ?
Comment 5 Michael Weghorn 2019-03-16 17:31:38 UTC
Thanks for testing.

What you can do is test whether the issue is also fixed if you use a daily build of LibreOffice 6.2 [1]. If the problem is gone there as well, it may well be that

1) Either the issue will be fixed with LibreOffice 6.2.2, due to be released next week.
2) Or it's some kind of distribution-specific thing (e.g. in the OpenSUSE packaging), in which case it's probably best to report a bug in the OpenSUSE bug tracker.


If you think that 2) is the case, you can also download LibreOffice 6.2.1 from the LibreOffice website now and see whether that one works. Since the same version from OpenSUSE doesn't work for you, that would mean there isn't much we can do from our side.

[1] https://dev-builds.libreoffice.org/daily/libreoffice-6-2/
Comment 6 Robert Cabane 2019-03-16 17:55:49 UTC
Additional note : I almost never use the distribution-specific build of LO, so this bugreport really concerns TDF's build.
Comment 7 Robert Cabane 2019-03-17 16:51:47 UTC
Good new again : I just installed 
https://dev-builds.libreoffice.org/daily/libreoffice-6-2/Linux-rpm_deb-x86_64@86-TDF/2019-03-16_01.33.35/libreoffice-6-2~2019-03-16_01.33.35_LibreOfficeDev_6.2.3.0.0_Linux_x86-64_rpm.tar.gz
with the "parallel installation" method.
Launched as :
./opt/libreofficedev6.2/program/soffice
Starts without any problem.

About :
=======================
Version: 6.2.3.0.0+
Build ID: 2358c867563731f56cefbf2a17818e69b15c2e66
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-16_01:33:35
=======================

=> WORKSFORME ?
Comment 8 Michael Weghorn 2019-03-17 17:43:55 UTC
(In reply to Robert Cabane from comment #7)
> Good new again : I just installed 
> https://dev-builds.libreoffice.org/daily/libreoffice-6-2/Linux-rpm_deb-
> x86_64@86-TDF/2019-03-16_01.33.35/libreoffice-6-2~2019-03-16_01.33.
> 35_LibreOfficeDev_6.2.3.0.0_Linux_x86-64_rpm.tar.gz
> with the "parallel installation" method.
> Launched as :
> ./opt/libreofficedev6.2/program/soffice
> Starts without any problem.
> 
> About :
> =======================
> Version: 6.2.3.0.0+
> Build ID: 2358c867563731f56cefbf2a17818e69b15c2e66
> CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time:
> 2019-03-16_01:33:35
> =======================
> 
> => WORKSFORME ?

Thanks for testing again and nice to hear this is working.

Yes, let's mark as WORKSFORME then.
Comment 9 Robert Cabane 2019-03-17 17:50:35 UTC
Thank you for the upcoming 6.2.0.3 !
Comment 10 Robert Cabane 2019-03-17 17:51:30 UTC
Oh no :-( 6.2.3 I meant  !
Comment 11 Robert Cabane 2019-04-22 13:23:26 UTC
Hello, I've just downloaded the freshly released LO version 6.2.3.
Bad news :-(
The same behaviour as previously reported happens. Even worse : I get no error message at all. The command line
SAL_USE_VCLPLUGIN=gen /opt/libreoffice6.2/program/soffice -v --safe-mode
does *exactly* nothing.
My system is still OpenSUSE 15.0 + KDE.

Shouldn't we reopen this bugreport ? "WORKSFORME" isn't really the right thing here ...
Comment 12 Michael Weghorn 2019-04-23 16:12:13 UTC
Yes, let's reopen this.

Since the problem happens with SAL_USE_VCLPLUGIN=gen, it doesn't really sound like a KDE-specific issue at first sight. some more questions:

1) Does that same happen when you use the same packages and the "parallel installation", i.e. extract the content to somewhere in the user directory?

2) Does the issue still occur when you remove/rename the user profile, located at '~/.config/libreoffice'?

3) Does it work when you use another VCL plugin, e.g. start with  SAL_USE_VCLPLUGIN=gtk3 (requires the "libobasis*-gnome-integration" package), SAL_USE_VCLPLUGIN=kde4, SAL_USE_VCLPLUGIN=gtk or SAL_USE_VCLPLUGIN=kde5?

4) Can you try to get a backtrace as described at [1]?

[1] https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 13 Robert Cabane 2019-04-23 17:19:28 UTC
Thank you for your advice. So I've made more tests. I reinstalled LO 6.2.3 from scratch and launched it, having previously erased my user profile.
First attempt :
/opt/libreoffice6.2/program/soffice -writer
Strange : the 6.1.3 version (from openSuSE) launched instead.
Second attempt :
SAL_USE_VCLPLUGIN=gtk3 /opt/libreoffice6.2/program/soffice -writer
Same behaviour.
Third attempt :
SAL_USE_VCLPLUGIN=gtk3 /opt/libreoffice6.2/program/soffice
LO6.2.3 started, creating a new user profile. Error message displayed on the terminal :
(soffice:8940): Gdk-WARNING **: XSetErrorHandler() called with a GDK error trap pushed. Don't do that.
Fourth attempt :
/opt/libreoffice6.2/program/soffice
LO6.2 launched, error message on the terminal :
QXcbConnection: XCB error: 3 (BadWindow), sequence: 2076, resource id: 25180684, major code: 40 (TranslateCoords), minor code: 0

Finally, I think everything works now. Seems that I had some kind of cache-related bug.

WORKSFORME
Comment 14 Michael Weghorn 2019-04-23 18:46:04 UTC
Thanks for the quick reply.

(In reply to Robert Cabane from comment #13)
> First attempt :
> /opt/libreoffice6.2/program/soffice -writer
> Strange : the 6.1.3 version (from openSuSE) launched instead.
> Second attempt :
> SAL_USE_VCLPLUGIN=gtk3 /opt/libreoffice6.2/program/soffice -writer
> Same behaviour.

Strange. As far as I know, this can happen if another instance of LibreOffice 6.1.3 is still running.

> Finally, I think everything works now. Seems that I had some kind of
> cache-related bug.
> 
> WORKSFORME

Nice to hear it's working again. Closing as WORKSFORME then, as suggested.