Bug Hunting Session
Bug 124111 - Cannot enter negative number for cross other axis at value
Summary: Cannot enter negative number for cross other axis at value
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: bibisected, regression
: 123520 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-15 22:34 UTC by wpeaton4
Modified: 2019-03-21 15:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (13.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-03-18 21:57 UTC, raal
Details
printscreen (40.84 KB, image/png)
2019-03-18 21:58 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wpeaton4 2019-03-15 22:34:53 UTC
I suspect this issue exists for all architectures and OS.

The cross other axis at value control will only accept positive values. If you enter a negative number, it will force to zero.

I have quite a few old spreadsheets with charts in them that have negative crossover points. They will display fine upon open. And they will show zero in the cross other axis at value control.
Comment 1 raal 2019-03-16 20:08:14 UTC
Confirm with LO 6.3, Linux. Regression in 6.2, but cannot bibisect, lots of crashes during bibisect.
Comment 2 wpeaton4 2019-03-17 00:05:03 UTC
Does not occur in 6.0.7.3 on Linux
Comment 3 Xisco Faulí 2019-03-18 21:29:45 UTC
Hi raal, wpeaton4@gmail.com,
Could you please explain the steps to reproduce this issue ( and attach a document if needed ) ?
Comment 4 raal 2019-03-18 21:57:24 UTC
Created attachment 150085 [details]
test file

open attached file
double click chart to edit 
right click X axis-properties
tab Positioning
set value= -1
Comment 5 raal 2019-03-18 21:58:15 UTC
Created attachment 150086 [details]
printscreen

this value cannot be changed under zero
Comment 6 Xisco Faulí 2019-03-18 23:04:15 UTC
The behaviour was correct until https://cgit.freedesktop.org/libreoffice/core/commit/?id=8947c9b1d8cd407131fdfb6fc3c77c8532e9d2a0 when LibreOffice started to crash when the dialog was launched. Later, the crash got fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=11300c48d4350c2f6748a1ca04b919cfae338d41 and the problem is already reproducible since then...

Adding Caolán to the loop...
Comment 7 Commit Notification 2019-03-19 15:43:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/93b562432a2f4d0a37afcfa89a4e88c83c229157%5E%21

Resolves: tdf#124111 Cannot enter negative number

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2019-03-19 16:03:57 UTC
fixed in master, backports in gerrit
Comment 9 Xisco Faulí 2019-03-20 16:01:57 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: eb128a7d6bbc27b4dbbf9461c81c90e40203b114
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán McNamara, thanks for fixing this issue!!
Comment 10 Commit Notification 2019-03-20 16:03:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/19a798d7576e5daa25e273cb14badfaacd8639dc%5E%21

Resolves: tdf#124111 Cannot enter negative number

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-03-21 05:52:24 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1c12cc16cfc89d58941e7b364304d3220e61f3dd%5E%21

uitest for bug tdf#124111

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2019-03-21 15:45:49 UTC
*** Bug 123520 has been marked as a duplicate of this bug. ***