Download it now!
Bug 124133 - EMF in PPTX wrongly imported
Summary: EMF in PPTX wrongly imported
Status: RESOLVED DUPLICATE of bug 136836
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2019-03-17 19:18 UTC by Frederic Parrenin
Modified: 2020-09-22 07:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
.pptx file to reproduce the problem (157.31 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-03-17 19:18 UTC, Frederic Parrenin
Details
EMF from the PPTX (1.69 MB, application/pdf)
2019-03-17 21:29 UTC, Aron Budea
Details
Screenshot in PP (54.59 KB, image/png)
2019-03-17 21:31 UTC, Aron Budea
Details
EMF image extracted from PPTX (1.69 MB, image/x-emf)
2019-03-19 09:47 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2019-03-17 19:18:58 UTC
Created attachment 150026 [details]
.pptx file to reproduce the problem

Steps to reproduce the problem:
- open the attached pptx file in PowerPoint
- open the same file in Impress
- compare slide 1
=> the two diagrams are different
Comment 1 Roman Kuznetsov 2019-03-17 20:02:44 UTC
(In reply to Frederic Parrenin from comment #0)
> Created attachment 150026 [details]
> .pptx file to reproduce the problem
> 
> Steps to reproduce the problem:
> - open the attached pptx file in PowerPoint
> - open the same file in Impress
> - compare slide 1
> => the two diagrams are different

Frederic, can you attach screenshot side-by-side for chart PowerPoint vs Impress?
Comment 2 Aron Budea 2019-03-17 21:29:53 UTC
Created attachment 150036 [details]
EMF from the PPTX

This is actually an EMF import problem, as the chart is simply an EMF file.
The equations are overlaid in the PPTX.
Comment 3 Aron Budea 2019-03-17 21:31:12 UTC
Created attachment 150037 [details]
Screenshot in PP
Comment 4 Aron Budea 2019-03-17 21:32:25 UTC
Repro in LO 6.3.0.0.alpha0+ (ec3aee0ef36f1ec3848581009b0de01e0ffd5e8f), 4.0.0.3 / Windows 7.
Comment 5 Bartosz 2019-03-19 09:47:07 UTC
Created attachment 150094 [details]
EMF image extracted from PPTX
Comment 6 Aron Budea 2019-03-19 13:18:58 UTC
Comment on attachment 150036 [details]
EMF from the PPTX

(In reply to Bartosz from comment #5)
> Created attachment 150094 [details]
> EMF image extracted from PPTX
Yep, it was already attached. :)
Comment 7 Timur 2020-09-22 07:15:49 UTC
Looks duplicate, git checkout db319c495cf1166af537d7054b0ddc23e17e46d3 in 7.1+.

*** This bug has been marked as a duplicate of bug 136836 ***
Comment 8 Timur 2020-09-22 07:29:49 UTC
This was a duplicate of at least bug 114187, so I remind to search before reporting and confirming.
Comment 9 Frederic Parrenin 2020-09-22 07:51:48 UTC
@Timur: thanks for the update.
I usually try to search for already reported bugs, but it is not always obvious to know if a bug is really the same bug for these import problems.