Download it now!
Bug 124192 - Doubled global menu bar in Ubuntu Unity environment
Summary: Doubled global menu bar in Ubuntu Unity environment
Status: RESOLVED DUPLICATE of bug 124391
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-19 02:13 UTC by c4pp4
Modified: 2019-10-27 19:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Menu comparison (90.62 KB, image/png)
2019-03-19 02:14 UTC, c4pp4
Details
LO-Snap-menu (125.09 KB, image/jpeg)
2019-05-01 08:52 UTC, Mike
Details
LO-native-menu (129.68 KB, image/jpeg)
2019-05-01 08:52 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description c4pp4 2019-03-19 02:13:01 UTC
Description:
OS Ubuntu 18.10 (cosmic) with Unity environment. After update of LibreOffice packages from version 6.1.2-0ubuntu1 to 6.1.5-0ubuntu0.18.10.1 there is doubled global menu in title bar.

Steps to Reproduce:
1. Boot Ubuntu 18.10 (cosmic) or live iso
2. Install ubuntu-unity-desktop package
3. Login into Unity environment
4. Launch LibreOffice Writer (6.1.5-0ubuntu0.18.10.1)
5. Hover mouse over title bar to make global menu visible

Actual Results:
Global menu is doubled

Expected Results:
One global menu set


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Global menu is OK after downgrade to version 6.1.2.
I also tested Ubuntu 19.04 (disco daily) version 6.2.1-0ubuntu1 and it has the same behavior as 6.1.5.
Comment 1 c4pp4 2019-03-19 02:14:47 UTC
Created attachment 150089 [details]
Menu comparison
Comment 2 Xisco Faulí 2019-03-20 23:09:43 UTC
The was a similar problem in KDE ( bug 123416 )
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 c4pp4 2019-03-25 10:47:44 UTC
Latest version (6.2.2) from the link has the same behavior.
Comment 4 mfco 2019-03-27 22:40:47 UTC
Description:
OS Ubuntu 16.04. After update of LibreOffice packages from version 6.1.2 to 6.1.5 there is doubled global menu in title bar.

I have this problem on 2 computers running ubuntu 16.04.  Both have only Libreoffice-writer,  Libreoffice-calc and Libreoffice-draw installed.

If I use symantic to uninstall Libreoffice-gtk3, LO looks as it should with only one menu. When I open a existing file using the open file icon LO reverts back to having two menus.

If I close LO and use Nautilus to open a LO file all is well with only one menu.

Making a test file and saving it then bringing it back with open file results in a double menu.

One computer is running 6.1.5 the other 6.2.2,  I did a total reinstall of 6.2.2
Comment 5 Grey 2019-04-07 06:30:15 UTC
Same problem here (LO 6.2.2.2 on Ubuntu 16.04). If a file is opened from Nautilus, the menu bar appears normal but opened from LO the doubled menu bar appears.
Comment 6 Grey 2019-04-07 06:49:09 UTC
(In reply to Grey from comment #5)
> Same problem here (LO 6.2.2.2 on Ubuntu 16.04). If a file is opened from
> Nautilus, the menu bar appears normal but opened from LO the doubled menu
> bar appears.

Sorry (no comment editing), I should clarify if a file is opened while LO is closed it opens normally. If LO is open and a file is opened either from LO or from the file manager the doubled menu bar appears. Additionally, in my case OpenGL/OpenCL are both disabled.
Comment 7 Mike 2019-05-01 08:50:37 UTC
I was the one reported the original KDE bug mentioned above.

While in Plasma with native package global menu is correct, the bug still exists on the latest LO when using snap LO.
What is noticeable, that not only the menu is doubled but has exactly the same look like the old Plasma bug, meaning it has no icons. Fixed, working version not only behaves correctly but has all the icons with the options.

The fact that the issue persists in newer versions of snap on Plasma global menu (I'm surprised that snap is even capable of passing global menus through to Plasma DE).

This could be a completely different bug but it is suspicious that it looks similar. Snap LO uses gtk default adwaita look if that matters.

Anyway, I'm posting screenshots between native Plasma and snap version. Both have the same version 6.2.3-2 and yet the difference is stellar when it comes to menus.

Here is my currents system info:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.3
Kernel Version: 5.0.10-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7,7 GiB
Comment 8 Mike 2019-05-01 08:52:09 UTC
Created attachment 151108 [details]
LO-Snap-menu
Comment 9 Mike 2019-05-01 08:52:40 UTC
Created attachment 151109 [details]
LO-native-menu
Comment 10 mfco 2019-05-08 21:23:07 UTC
Version: 6.2.3.2
Build ID: 1:6.2.3-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Still not fixed
Comment 11 Thomas Mohr 2019-05-18 19:35:01 UTC
Same bug on Ubuntu 18.04 LO 6.2.3.2.
Comment 12 OfficeUser 2019-07-27 09:29:57 UTC

*** This bug has been marked as a duplicate of bug 124391 ***
Comment 13 Andreas B. 2019-10-27 19:57:40 UTC
Still reproducible with 6.3.2.2 on Ubuntu 18.04