Download it now!
Bug 124217 - Themes do not get correctly applied on tabbed user interface
Summary: Themes do not get correctly applied on tabbed user interface
Status: RESOLVED DUPLICATE of bug 121877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed LibreOffice-Themes
  Show dependency treegraph
 
Reported: 2019-03-19 21:57 UTC by Aritz Erkiaga
Modified: 2019-09-12 09:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
different firefox theme support (505.01 KB, image/png)
2019-03-20 10:23 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aritz Erkiaga 2019-03-19 21:57:21 UTC
Description:
Firefox themes are not properly visible when user interface is tabbed.

Steps to Reproduce:
1. Go to Tools -> Options... -> LibreOffice -> Personalization
2. Select a preinstalled theme
3. Set View -> User Interface -> Tabbed

Actual Results:
The toolbar is completely white, with only two themed stripes at the top and bottom.

Expected Results:
The whole toolbar should have the theme applied.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: CL
Comment 1 andreas_k 2019-03-20 10:23:14 UTC
Created attachment 150114 [details]
different firefox theme support

screenshot of all tabbed notebookbar layouts in
- gtk3
- windows
- qt

all three use different implementations. I don't know what's the best one, I tend to prefer the windows implementation where you have only the colored background in the tabbed line. But I also like the one from gtk3 where the toolbar content area is colored (the focus is more where the UI elements are). Have everywhere an background color, I think it's not very sexy.
Comment 2 Timur 2019-09-12 09:52:28 UTC
I didn't check details, but by name this seems like a duplicate. 
If not, set back New and explain.

*** This bug has been marked as a duplicate of bug 121877 ***