Download it now!
Bug 124229 - External Clipboard does not paste into LibreOffice Writer
Summary: External Clipboard does not paste into LibreOffice Writer
Status: RESOLVED DUPLICATE of bug 122689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-20 18:24 UTC by David Ring Jr
Modified: 2019-03-20 23:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Ring Jr 2019-03-20 18:24:15 UTC
Description:
LO Writer 6.2.1.2 Will Not Paste External Clipboard Correctly  edit
copy
paste
linux
writer
asked just now

djringjr gravatar image
djringjr 
1
Copy from external program to paste into LO Writer 6.2.1.2 does not work.

Can cut from LO Writer then paste OK but I cannot copy from Firefox or Chromium browser or any external program (like Notepad+) into LO Writer.

Copy from external program using menu or control-C and pasting into LibreOffice Writer 6.2.1.2 does not update LO clipboard, when I use "paste" or Ctrl-v the LAST copied data in LO gets pasted, not the newly copied data.

If I open a text program like Kate I can paste, I can paste into Firefox or Chromium, but when I go to LO Writer, I cannot paste the new clipboard, only the last previously copied data in LibreOffice. If I go to another program (as previously stated) I do get the new data.

LibreOffice Writer Version: 6.2.1.2 Build ID: 6.2.1-1 CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; Locale: en-US (en_US.UTF-8); UI-Language: en-US Calc: threaded

5.0.2-arch1-1-ARCH #1 SMP PREEMPT Thu Mar 14 18:47:49 UTC 2019 x86_64 GNU/Linux

Steps to Reproduce:
1. Copy LibreOffice Writer
2. Copy from another program 
3. Paste into Libreoffice Writer - the copy from LibreOffice Writer (step #1) will paste, not the copy from #2)



Actual Results:
Last Copy from LibreOffice will be pasted.

Expected Results:
External Copy should paste into LibreOffice Writer.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-03-20 23:07:00 UTC
Thanks for reporting this issue.
This is a duplicate of bug 122689, which is fixed in LibreOffice 6.2.2.2, which is released this week.

*** This bug has been marked as a duplicate of bug 122689 ***