Bug 124238 - Show a Tip-Of-The-Day dialog on startup
Summary: Show a Tip-Of-The-Day dialog on startup
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.3.0
Keywords:
: 124697 (view as bug list)
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-03-21 09:13 UTC by Heiko Tietze
Modified: 2019-11-23 10:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
First step (38.56 KB, image/png)
2019-03-21 14:18 UTC, Heiko Tietze
Details
Final design (28.68 KB, image/png)
2019-03-27 12:34 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2019-03-21 09:13:06 UTC
The awesome list of tips being showed on Twitter should become available for everyone by presenting a Tip-Of-The-Day dialog on startup.
Comment 1 Roman Kuznetsov 2019-03-21 10:37:44 UTC
(In reply to Heiko Tietze from comment #0)
> The awesome list of tips being showed on Twitter should become available for
> everyone by presenting a Tip-Of-The-Day dialog on startup.

Heiko, where will this dialogue get text for "Tip-Of-The-Day"?
Comment 2 Heiko Tietze 2019-03-21 11:16:59 UTC
We do have a long list here https://pad.documentfoundation.org/p/marketing (line 388ff) that will go into strings.hrc for translation. I'd also appreciate to show small images on the tip a) for aesthetics and b) to illustrate the tip.
Comment 3 Heiko Tietze 2019-03-21 14:18:57 UTC
Created attachment 150147 [details]
First step

The design is not finished, just a sneak preview.
Comment 4 Heiko Tietze 2019-03-27 12:34:48 UTC
Created attachment 150307 [details]
Final design

Some minor bits are still missing but the design is what I had in mind.
Comment 5 Commit Notification 2019-04-10 14:56:17 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a1700d52a47184ee07b91b461a846dc5435f0022%5E%21

tdf#124238 - Show a Tip-Of-The-Day dialog on startup

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-04-12 07:54:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a62eacace46f5057f5b771448a0d0c443d3a4ea3%5E%21

Related: tdf#124238 don't assert on closing new TipOfTheDayDialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Heiko Tietze 2019-04-12 11:00:54 UTC
*** Bug 124697 has been marked as a duplicate of this bug. ***
Comment 8 cwvb 2019-09-01 13:49:19 UTC
only a question: How can I reach 'Tipp of the Day' wenn I deactivated the automatical launching option?
Comment 9 Aron Budea 2019-09-02 02:36:26 UTC
(In reply to cwvb from comment #8)
> only a question: How can I reach 'Tipp of the Day' wenn I deactivated the
> automatical launching option?
You can open Options, navigate to Libreoffice -> General, and tick 'Show "Tip of the Day" dialog on start-up'.
Comment 10 Heiko Tietze 2019-09-02 06:04:30 UTC
(In reply to Aron Budea from comment #9)
> You can open Options, navigate to Libreoffice -> General, and tick 'Show
> "Tip of the Day" dialog on start-up'.

You cannot open the dialog manually, I don't see need for this. Just reactivate the daily tip per Tools > Options > View.
Comment 11 Luca 2019-11-23 05:57:54 UTC
(In reply to Heiko Tietze from comment #10)

> You cannot open the dialog manually, I don't see need for this. Just
> reactivate the daily tip per Tools > Options > View.

1) I second the request for a "manually open tip of the day" , because it's only possible to see tips of the day once per day. If you accidentally (or willingly) close the dialog, you have to wait till next morning to reopen it. 

2) I can't check the English version because of the above problem, but in Italian at least, there is no line wrap for the text in the Tip of the day box. It goes off the window on the right.
Comment 12 Justin L 2019-11-23 10:52:01 UTC
(In reply to Luca from comment #11)
> (In reply to Heiko Tietze from comment #10)
> 1) I second the request for a "manually open tip of the day" , because it's
> only possible to see tips of the day once per day. If you accidentally (or
> willingly) close the dialog, you have to wait till next morning to reopen
> it.
It will be available in the help menu in LO 6.4 courtesy of bug 127400.

> 2) I can't check the English version because of the above problem, but in
> Italian at least, there is no line wrap for the text in the Tip of the day
> box. It goes off the window on the right.
There have been some fixes related to width. From what I can see, wrapping is enabled, so it SHOULD not be a single line. See bug 127994. If you find problems when testing LO 6.4, create a new bug report.