Bug 124241 - Window too large to get to okay on 1600x900 display [conditional formating, cell style]
Summary: Window too large to get to okay on 1600x900 display [conditional formating, c...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-03-21 14:42 UTC by Rob
Modified: 2019-05-01 13:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen copy showing style dialog from Calc (327.39 KB, image/png)
2019-04-30 08:10 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2019-03-21 14:42:44 UTC
Description:
When I try to do conditional formatting the okay and cancel buttons are off the bottom of the screen.  I have to try to move the window up and can just see the buttons but not the text of the button.  It seems the font selection tab is too large for smaller screens and has made the overall window too large.

Steps to Reproduce:
1. Highlight a column
2. Menu [Format --> Conditional --> Condition]
3. Enter value in condition 1
4. Click 'Accent' drop down
5. Select 'New Style' from drop down


Actual Results:
Organiser window has large empty space and buttons are off the bottom of the screen. Font and numbers seem to be the reason for the large size but could be reduced.

Expected Results:
A smaller window that fits on small displays.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-03-21 16:44:49 UTC
Thanks for reporting this issue.
This is a duplicate of bug 122480 and it's fixed in LibreOffice 6.2.1.2

*** This bug has been marked as a duplicate of bug 122480 ***
Comment 2 Jean-Baptiste Faure 2019-04-30 08:09:38 UTC
(In reply to Xisco Faulí from comment #1)
> Thanks for reporting this issue.
> This is a duplicate of bug 122480 and it's fixed in LibreOffice 6.2.1.2
> 
> *** This bug has been marked as a duplicate of bug 122480 ***

I disagree: bug 122480 has been filed for Writer. This one is filed for Calc and is still reproducible with version 6.2.3 whereas bug 122480 is still fixed for Writer.

Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Best regards. JBF
Comment 3 Jean-Baptiste Faure 2019-04-30 08:10:36 UTC
Created attachment 151082 [details]
screen copy showing style dialog from Calc
Comment 4 Jean-Baptiste Faure 2019-04-30 08:17:35 UTC
Added regression keyword because it works as expected in LO 6.1.

Of course reproducible in current master.

@Caolan: you may be interested in this bug as it is similar to bug 122480.

Best regards. JBF
Comment 5 Caolán McNamara 2019-04-30 10:38:33 UTC
Can't reproduce it, but I imagine the same fix as the other ones would work here too https://gerrit.libreoffice.org/#/c/71577/
Comment 6 Commit Notification 2019-04-30 14:26:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1ae5ca077119982ae83833871326c86d9930ae11%5E%21

tdf#124241 let dialog be resizable

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2019-04-30 14:27:48 UTC
if that works, let me know and its trivial to backport to 6-2
Comment 8 Jean-Baptiste Faure 2019-05-01 05:27:27 UTC
(In reply to Caolán McNamara from comment #7)
> if that works, let me know and its trivial to backport to 6-2

Yes it works on my own build of the master! Please, do the backport to 6.2.

Thank you very much for the quick resolution.

Best regards. JBF
Comment 9 Commit Notification 2019-05-01 06:35:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/df02927207ad19532f5c1ac5a5cf745559e47c22%5E%21

tdf#124241 let dialog be resizable

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2019-05-01 13:35:04 UTC
Verified fixed in Version: 6.2.4.0.0+
Build ID: df02927207ad19532f5c1ac5a5cf745559e47c22
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

and in Version: 6.3.0.0.alpha0+
Build ID: f7453b956bcf83ec13c805d243f20cb209289179
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Thank you very much!

Best regards. JBF